I prefer Abiword instead of Libreoffice, so i right-clicked on an opendocument-file, selected "open with" and in the window I chose to make it open with the command "abiword", and when I double-click the document it opens in abiword, but in the launcher it shows a gray question mark instead of the abiword icon. It's a minor thing I know, but it bugs me. How can you start it and have the real icon show?


Have you tried to, instead of opening a document, open Abiword through Menu > Applications?


Try this:

  1. open AbiWord from your applications menu (Super + A)
  2. once AbiWord is open look to see if its icon is present in the Launcher. If not, I don't know. But if so you can right-click this Launcher icon and select the Pin to launcher option
  3. now try opening a document and see if it uses the "?" icon or the AbiWord icon.
  • It works fine if I do it that way, but I want to be able to open it from the file manager and still have consistent icons, is that possible? – Konstapel Kask Apr 21 '11 at 18:42
  • Once you pin the "non-?" icon to the Launcher try opening from the File Manager with the expectation that it will now use the "non-?" icon. That is, does it still use the ? icon even after pinning the graphical icon to the LauncheR? – sam Apr 21 '11 at 19:02
  • No, it does not, it creates a ?-icon, even if the real deal is pinned – Konstapel Kask Apr 21 '11 at 23:30
  • @Martin Josefsson: when you open a folder in nautilus and look at an AbiWord file, it has an icon or it has "?" ? – desgua Apr 22 '11 at 1:58
  • Nope, then it works as expected with the Abiword icon. – Konstapel Kask Apr 22 '11 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.