I was trying to install Teamviewer, but I was getting a dependency error. I tried to install the required packages, but with no luck.

I'm getting this error:

Unpacking teamviewer (from teamviewer_linux_x64.deb) ...
dpkg: dependency problems prevent configuration of teamviewer:
 teamviewer depends on lib32asound2; however:
  Package lib32asound2 is not installed.
 teamviewer depends on lib32z1; however:
  Package lib32z1 is not installed.
 teamviewer depends on ia32-libs; however:
  Package ia32-libs is not installed.

dpkg: error processing teamviewer (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 teamviewer

I tried

sudo apt-get -f install

Getting

Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32z1 lib32ncurses5 lib32bz2-1.0

Package lib32asound2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'lib32asound2' has no installation candidate
E: Package 'ia32-libs' has no installation candidate

I can't even get to the

sudo dpkg -i teamviewer_linux_x64.deb

If I force installation

sudo dpkg --force-depends -i teamviewer_linux_x64.deb

Although it's "Setting up Temviewer" it gives me this:

Enter image description here

How can I fix this problem?

up vote 295 down vote accepted

The problem is that the teamviewer_linux_x64.deb, the package that was aimed to 64-bit systems, uses a obsolete package that tried to achieve multiarch previously in Debian based systems called ia64-libs. Although, that package scheme changed and now Teamviewer distribute the native build for both i386 and amd64 architecture, as they don't need anymore multiarch.

Simply downloading the appropriated package for Debian/Ubuntu and installing it using your favorite method, should be enough. This package also installs a repository, so it should also automatically upgrade itself when you upgrade your system.

  • 13
    I've tried Gdebi method, but it didn't helped. I'm getting: Dependency is not satisfiable: lib32asound2 – Slava Fomin II Dec 16 '13 at 11:09
  • 4
    @SlavaFominII install 32-bit instead – ssgao Feb 10 '14 at 22:23
  • 2
    what does :i386 mean? I'm on x64, should I use :i386? – アレックス Mar 22 '14 at 5:34
  • 2
    i386 refers to the 32-bit edition of windows and amd64 (or x86_64) refers to the 64-bit edition. -- this is what I said. Whereas you said that i386 was 64-bit – アレックス Mar 22 '14 at 14:00
  • 2
    @Alex you don't understand. They doesn't have a 64-bit binary for TeamViewer, so they were relying in ia32-libs and now multiarch so their 32-bit binaries works in 64-bits systems. – Braiam Mar 31 '14 at 3:19

All I had to do to amend this problem was do dpkg --force-all -i *.deb to install that package. Note that the only dependency it couldn't resolve was libpng12-0, so after forcing the install it has no images in the interface but it is still runnable. The other solutions did not solve the problem for me. I'm hoping the Teamviewer developers will get to this soon.

  • I do the same conclusion as you. Did you contacted the teamviewer support service ? Did you obtained any response from them ? Have you got a solution ? – Rémi B. Nov 16 '16 at 14:36
  • 1
    I never contacted them, just because in my experience no company wants to support Linux so I always just get my help here. – wjrochester Nov 16 '16 at 16:03
  • Ok thank you for your reactivity. We can't same the same about the TeamViewer team, these arch and missing dependency issues are there in each new major version. They don't care about us, its so ridiculous. Its just about build a clean package for their software... And we pay for that.. – Rémi B. Nov 16 '16 at 16:34
  • My skills are nowhere near good enough to do it myself, but I suppose what you can do is remove the dependency for the libpng package that doesn't work from the list of dependencies for TeamViewer, then add a different package that has full PNG support and then program that one in manually. I don't know if this is possible or easy to do, but if we take it upon ourselves to make a different package work for this program we can make it work I think. – wjrochester Nov 16 '16 at 16:36

You need to install all dependency libraries for i386 (this might work with 64 too) as described above. For the missing libpng12 library just go to: https://packages.debian.org/jessie/i386/libpng12-0/download and install with

sudo dpkg -i ~/Downloads/libpng12-0_1.2.50-2+deb8u3_i386.deb

it has no dependencies which wouldn't be resolved by current environemnt:

dep: libc6 (>= 2.14), zlib1g (>= 1:1.1.4)

TeamViewer 13.0 preview for Linux

TeamViewer 13.0 is preview is out for Linux and it's no longer based on Wine. TeamViewer 13.0 features native 64-bit support and a Qt front-end. .deb packages for TeamViewer 13.0 for preview for Linux are available from the official TeamViewer website.

On Ubuntu 17.10 some features of TeamViewer require Xorg to be selected instead of the default Wayland at the login screen. In Wayland only outgoing remote control and incoming file transfer are supported. If you need incoming remote control you have to login to classic Xorg. In order to enter an X session from the GDM login screen select Ubuntu on Xorg.

protected by Community Dec 5 '13 at 15:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.