I am trying to install Xubuntu 13.10 on a G75VX laptop which has Windows 8 Pre-Installed. So my installation has to be in EFI mode. I've had Xubuntu 13.10 installed in it for a while on a different hard drive and it worked just fine. When i try to install in EFI mode it boots but I get a blank screen after booting. Adding nomodeset to grub like I've done to install in legacy mode will not resolve the issue.

This installation will have the following:

EFI boot.Cannot install Legacy mode due to Pre-installed Windows 8 Ubuntu will be installed on a secondary HDD by itself Along with Windows 8 on Primary HDD. Nvidia Graphics GTX670MX.

Any help will be greatly appreciated.


Can you boot the installer in legacy (aka CSM or BIOS) mode? If you can, then you can:

  1. Install Linux in BIOS/CSM/legacy mode.
  2. In Windows, install my rEFInd boot manager.
  3. Edit the refind.conf file: Uncomment the scanfor line and ensure that hdbios is among the options.

The result should be that rEFInd will appear when you reboot, and it will give you at least two boot options: One for Windows and one with a gray diamond icon that will boot to the BIOS-mode GRUB, and from there to Linux. You can also add an EFI filesystem driver for ext4fs (or whatever filesystem holds your Linux kernel) to experiment with direct EFI-mode booting. If you can eventually get this to work (because of kernel upgrades or whatever special kernel options overcome the problem), you can switch to a direct EFI-mode boot of Linux.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.