25

How to fix black or broken plymouth (splash screen) after installation of nvidia proprietary drivers in Ubuntu (it happens usually in all Ubuntu releases)? It's no matter what version of nvidia drivers I install bug is always present.

  • Works OK but in my case, GeForce 7300 LE, I had to drop down the colour depth to 16 - ie. 1280x1024x16 instead of 1280x1024x24 as the latter gave a poor resolution on the plymouth screen. – gdesilva Apr 26 '14 at 6:48
  • Wonderful. It also works with Intel perfectly. Thanks – user284336 May 22 '14 at 20:04
  • possible duplicate of Enabling Nvidia driver messes up splash screen – Waldir Leoncio May 27 '14 at 8:47
  • Nope, in topics provied by you are outdated informations or missing/not needed to install packages. – Nolt Aug 25 '14 at 15:47
42

Here is a solution to address the problem of no plymouth (splash screen) in Ubuntu after an nVidia proprietary driver installation. It doesn't matter what Ubuntu version you use, it should work anyway.

Open your terminal and type

sudo apt-get install v86d

Then

sudo -H gedit /etc/default/grub

Find this line

#GRUB_GFXMODE=640x480

and change for this one (of course choose your resolution)

GRUB_GFXMODE=1440x900
GRUB_GFXPAYLOAD_LINUX=keep

Note: You can try GRUB_GFXMODE=1440x900x24, but beware of specifying the color depth. You must specify a supported value. If does not work then rather delete it. More information in the manual.

Also note: older Nvidia graphics cards require the GRUB_GFXMODE property in the format <width>x<height>-<depth> (e.g. 1920x1200-24, but not 1920x1200x24).

Save file and type in terminal

echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash
sudo update-initramfs -u
sudo update-grub

It worked for me in all Ubuntu versions. Give it a try :)

  • Is this still valid for AMD graphic cards? – João André Jan 28 '14 at 0:27
  • Unfortunately I don't have AMD graphic so you need a test by yourself. – Nolt Jan 30 '14 at 11:27
  • Already tested it, it works :) – João André Jan 30 '14 at 20:26
  • This solution only partially works for me on Ubuntu GNOME 15.04. I have a 1600x900 display, and an Nvidia Geforce GT 620. After following the steps here, the splash shows for a few seconds, then the screen goes black and only the animated dots show before the screen goes black again. – Alex Dueppen May 3 '15 at 18:39
  • 1
    @janoChen The solution still only partially works but I'm fine with it. I've heard that it's an issue with my graphics card being low-end so not getting as much driver support. – Alex Dueppen Feb 13 '16 at 4:21
5

If the above solution does not work, check that the $vt_handoff is used in the /boot/grub/grub.cfg file

In the file, search the line beginning with :

linux   /boot/vmlinuz ...

in the appropriate section of the boot menu (e.g. first occurrence of this line if you want to restore splash screen for the first grub menu boot option) and make sure that this line ends with

... quiet splash $vt_handoff

Here is the example in my case (commented line replaced by second line), replace the xxxx by the existing UUID of the boot partition :

#   linux   /boot/vmlinuz-3.13.0-24-generic root=UUID=xxxx ro   nmi_watchdog=0
    linux   /boot/vmlinuz-3.13.0-24-generic root=UUID=xxxx ro   quiet splash $vt_handoff
0

Nvidia proprietarty drivers doesn't support KMS, until recently. KMS is required for plymouth (splash screen) to work. It is a Nvidia problem (not ubuntu canonical). I would recommend leaving it like that (it doesn't affect your daily usage) and wait for nvidia 364.12 or newer in the Ubuntu repository. With nvidia 364.12 plymouth works.

If you are impatient, you can use this:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-364
  • this answer is intended for new ubuntu users – john9983 Jul 17 '16 at 9:12
  • For some reason, I can not use GPU rendering with Blender (CUDA) as soon as this driver is installed. – ByteHamster Aug 3 '16 at 18:37
  • Try a newer driver nvidia-367 – john9983 Sep 19 '16 at 12:56
  • 1
    @ByteHamster if I am not mistaken You need to install this package nvidia-cuda-dev to use CUDA. – Michal Przybylowicz Jul 7 '17 at 23:35
  • I don't know for sure, but I think the cuda package was installed. Anyway, I later switched to a completely different distro for other reasons (no Plymouth anymore). Thanks for your suggestion anyway! – ByteHamster Jul 8 '17 at 5:40

protected by Community May 27 '14 at 8:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.