50

So I have looked online (believe it or not) and I can't seem to find anything to help me with my issue. My clock just disappeared. Here's a screenshot!

disappeared clock

5
  • 1
    I had the same experience after upgrading from 13.04 to 13.10. It's one of the reasons why I'm not longer on 13.10.
    – user85164
    Oct 20 '13 at 21:06
  • This is NOT a duplicate of the said question. This is not happening in Gnome, but in Unity. FWIW, restarting unity brought it back in my case. Jan 21 '14 at 11:47
  • 1
    I think that it is not a off-topic, since to me it as just a mistake, removing some packages....
    – insign
    Nov 9 '15 at 13:33
  • Why is this off-topic? The one specified reason is question for development version of Ubuntu which is not the case here. Is the real reason that 13.10 is no longer supported? Should that be a reason for question to be off-topic?
    – okolnost
    Jun 14 '16 at 5:39
  • Answering my own question on why is this off-topic: meta.askubuntu.com/q/2448/2825
    – okolnost
    Jun 27 '16 at 17:12
47

Similar thing happened to me after upgrade to 13.10. I found that this bug describes it: https://bugs.launchpad.net/ubuntu/+source/indicator-datetime/+bug/1237361

I have it solved now, not sure if by installing system updates, by changing all related attributes in dconf-editor for node

com.canonical.indicator.datetime

or just by restarting unity (Alt+F2 -> "unity --replace") as commenter in above mentioned bug said it may help.

So maybe try to play a bit with settings and then trying restarting unity would not be a bad idea either.

3
  • 15
    (Dunno how this got marked as a duplicate — Unity ≠ Gnome.) Replacing unity can cause the window manager to fail, so you get windows without controls that you can't move or close. I've had the most success with sudo killall unity-panel-service, which reinstates the clock immediately.
    – scruss
    Feb 5 '14 at 13:40
  • 18
    for me, unity --replace was enough. thanks for that!
    – andreas-h
    Feb 21 '14 at 9:11
  • 5
    @scruss, you don't need the sudo. You can just run killall unity-panel-service as described in the bug, No clock in menu bar and can't edit Clock settings.
    – Don Kirkby
    Jun 17 '14 at 17:54
16

It's possible that it got uninstalled (most probably when you were trying to uninstall some other indicators). Try

sudo apt-get install indicator-datetime

And restart unity with

unity --replace

Then recheck your Clock settings. That should hopefully be the problem

2
  • 3
    Why the downvote? Oct 20 '13 at 21:06
  • 3
    After running above comment I needed to also restart unity with unity --replace and my clock was back
    – walkeros
    Aug 3 '15 at 5:48
7

For me check the clock settings solved the problem.. actually "Show a clock in the menu bar" was already checked, I had to uncecheck it, close the settings, reopen the settings, checked this option back and finally it worked.

5
  • It would have been good if you said where the clock settings were
    – Anake
    Jan 7 '14 at 19:43
  • 3
    @Anake: "System settings" -> "Time & Date" -> "Clock".
    – Antonello
    Jan 8 '14 at 7:38
  • that checkbox is grayed and I cant interact with it! Jan 16 '16 at 17:11
  • 5
    @AquariusPower A hearty killall unity-panel-service solves your problem. May 26 '16 at 19:34
  • Thanks @JonasGröger the killall was the solution Aug 15 '16 at 9:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.