Recently I have been messing with gnome-terminal to make it look more appealing. I tried using installed fonts that were in my ~/.fonts folder (installed with Font Viewer) but when I edit the gnome-terminal profile, the installed font doesn't show up.

The font that I am trying to use is cure.se.ttf, and every other program that allows font changing works, as well as it being intstalled globally.

Am I installing them wrong, or is there a certian place they need to be?


What worked for me is putting the font files in ~/.local/share/fonts and then running,

$ sudo fc-cache -vf ~/.local/share/fonts

The fonts in ~/.local/share/fonts are available for all apps now.


The configuration GUI seems to filter non-monospace fonts.

A workaround is to use dconf directly to set fonts:

# get your profile id
dconf list '/org/gnome/terminal/legacy/profiles:/'
# get your current font
dconf read '/org/gnome/terminal/legacy/profiles:/:PROFILE_ID/font'
# set the font, make sure you include those single quotes
dconf write '/org/gnome/terminal/legacy/profiles:/:PROFILE_ID/font' "'FreeMono 18'"

Had the same issue. Setting font permissions resolved my problem. For example:

chmod 755 ~/.fonts/cure.se.ttf

Then open new terminal instance.


Updating your font cache might solve the issue. Try to run the following command:

fc-cache -vf ~/.fonts
  • 2
    Just did again, still not working. – Mobo Oct 20 '13 at 19:22
  • There is probably a better way, but what worked for me was moving the fonts to the default location on /usr/share/fonts and them update the cache again. – evandromr Jun 6 '15 at 7:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.