:) I just installed Ubuntu 13.10 on my HP envy m6. When I press the "power" button and select to suspend, it looks like it goes to sleep (power light flashing, as expected).

When I press the power button to wake it (or anything else), it stops flashing and goes solid (as it should) but the screen is black.

I tried CTRL+ALT+F1 but nothing seems to happen.

Is there something I can do to get Ubuntu to resume from suspend?

EDIT: I tried getting any updates for Ubuntu as well as updating my BIOS. Neither seems to have any effect.

EDIT: Tried the 2nd script from Ubuntu 12.04 LTS suspend fix and it seemed to have no effect. Tried the 1st script and now I can't seem to suspend at all - Ubuntu seems to try to suspend and then immediately goes to the password prompt. With some combination of things I seem to be able to get a new crash, though, involving wpa_supplicant. I allowed it to submit feedback. My WiFi seems to be working fine (I assume this is what WPA is).

EDIT: I know this is 'askubuntu', but I did try latest Linux Mint / Cinnamon. Results were exactly the same (black screen, power light solid after waking up - just as before, I can make it reboot by mashing CTRL+ALT+DEL but CTRL+ALT+F1/etc. doesn't work). Trying Ubuntu 12.04 next.

EDIT: Ubuntu 12.04 WORKS! At least it seems to with a quick test. Came right back up after suspend. If I don't have any other problems and no answers are suggested, I'll make my own answer and accept it. Maybe someone can use this information to help troubleshoot the real issue. Would be nice to be on the latest version... but suspend would've been a deal-breaker for me. Hope this info helps someone.

EDIT: Installed proprietary ATI driver (not the experimental/beta one) and the issue is back. I can CTRL+ALT+F1 to go to terminal and then sudo stop lightdm, sudo start lightdm which seems to bring me back. The fixes in the forum post didn't fix it either, one prevents machine from suspending the other just doesn't seem to have an affect.

EDIT: Tried the fix here ati suspend issue but seem to get the same result. I noticed something new (which may have been there all along). Though screen is black, if I move the trackpad mouse as far right as possible, the mouse cursor appears at the left side of the screen. It can travel up/down, but not to the right. I can travel left "off" the screen, and seemingly pretty far.


I wish I had an answer, but I can at least commiserate with you. I have an Envy 15 and am experiencing the same problem you are.

I was previously running 13.04 and did not experience this problem, so it seems new to 13.10. I've tried everything you've tried, with no success. If I do find an answer, I'll come back here and let you know.

  • Thanks for posting this! Good to know I am not alone! :) You say 13.04 worked... Were you running ATI proprietary drivers by chance? Best of luck to you as well. :) Hope we find a solution soon. – aikeru Nov 5 '13 at 0:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.