I'm having problems trying to use my Nvidia 635M in my asus N46VJ laptop.

I open the "Nvidia X server settings" I get this message :

"You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server."

I open the terminal typi "sudo nvidia-xconf" and this creates a file,


After reboot I'm in a lower resolution of 640x480, without other options to change it, then open the Details system and it shows me this in the Graphic item:

Intel® Ivybridge Mobile

I type this in the terminal (no idea what that means, I just saw it in a forum!!!)

lspci -vnn | grep '\''[030[02]]'

and get this:

00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller]) 01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 635M] [10de:0de3] (rev a1) (prog-if 00 [VGA controller])

I installed bumblebee but nothings happens additionally the additional drivers shows me "no propietary Drivers are in use on this system"

  • Your question in its present form is confusing and will probably lead to you getting the wrong answer. According to your other question you have already tried installing an Nvidia driver on the same laptop. Please add this info from the other question to this question also.
    – karel
    Commented Oct 22, 2013 at 2:39
  • Hi thanks for your response, sorry for the confusing thing. Yeah, you'r right, I've tried to install the nvidia drivers in my laptop ( the same for both questions, Asus N46VJ). As I understand the blinking cursor after the grub menu is related with the fact that there's no working nvidia driver.
    – Andres
    Commented Oct 22, 2013 at 4:44
  • Yes, that's what happens when there's no working Nvidia driver. And if you did install any Nvidia driver, then you have to uninstall it before you install the new one. I can't tell you how to remove the old Nvidia driver because I don't know whether you installed it from the Ubuntu Software Center or if you downloaded it from the Nvidia website and installed that driver.
    – karel
    Commented Oct 22, 2013 at 4:48
  • I typed this in the terminal, 'sudo apt-get purge nvidia-current' and get all the listed items show "rc", except for the first one, "ii".
    – Andres
    Commented Oct 22, 2013 at 5:21
  • Hi, I clicked "Active" and now I got 1 of the 4 listed driver with a green dot and is says "nvidia_304". I opened Nvidia X server settings and still get the message:"You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.". Then open de terminal type "sudo nvidia-xconfig" and "sudo restart lightdm" then.. I stuck back in the 640X840 resolution. Should I try removing the actual driver and trying with some of the 3 left ? While booting there's no nvidia logo o something like that.
    – Andres
    Commented Oct 24, 2013 at 2:38

1 Answer 1


Sorry if this is way too basic and laughably simple, but it always works for me.

I would try this.

sudo apt-get install nvidia-current && sudo apt-get install nvidia-current-updates


sudo apt-get update && sudo apt-get upgrade

Reboot and cross your fingers. When it boots back up just make sure you're using the driver that you want in the device manager.

I usually install manually though. You can go to the Nvidia website and look up your driver. They even have detailed instructions on how to install it manually in Ubuntu. It's pretty easy, but again, if this problem is way out of my league I apologize. Just thought it might be worth a try.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .