3

I'm running Ubuntu 13.10 32bit with Gnome 3.8 but am missing the Ubuntu Software Center. I tried to install it via terminal:

$ sudo apt-get install software-center

But that tells me that dependencies are not met

The following packages have unmet dependencies:
    software-center : Depends: gir1.2-webkit-3.0 but it is not going to be installed

gir1.2-webkit-3.0 depends on gir1.2-javascriptcoregtk-3.0 of version 1.10.2-0ubuntu2. But that package is only available as version 2.0.4-2~ubuntu13.04.

I am missing the Ubuntu Software Center as well as the Update Manager and the packages update-notifyer and ubuntu-release-upgrader-gtk.

How can I install the packages with correct dependencies?


Edit:

Output of apt-cache policy gir1.2-javascriptcoregtk-3.0:

gir1.2-javascriptcoregtk-3.0:
  Installed: 2.0.4-2~ubuntu13.04.1
  Candidate: 2.0.4-2~ubuntu13.04.1
  Version table:
 *** 2.0.4-2~ubuntu13.04.1 0
    100 /var/lib/dpkg/status
     1.10.2-0ubuntu2 0
    500 http://de.archive.ubuntu.com/ubuntu/ saucy/main i386 Packages

My sources.list:

deb http://de.archive.ubuntu.com/ubuntu/ saucy main restricted universe multiverse
deb http://de.archive.ubuntu.com/ubuntu/ saucy-security main restricted universe multiverse
deb http://de.archive.ubuntu.com/ubuntu/ saucy-updates main restricted universe multiverse
deb http://archive.canonical.com/ubuntu saucy partner
deb http://extras.ubuntu.com/ubuntu saucy main

# spotify
deb http://repository.spotify.com stable non-free

Spotify I added myself.

  • You seem to be using outdated packages. You say you are on 13.10, but you gir... version is 2.0.4-2~ubuntu13.04, which is not even available on the Gnome 3 PPA. Please post the output of apt-cache policy gir1.2-javascriptcoregtk-3.0 and the relevant lines of your sources.list files. – Andrea Corbellini Oct 20 '13 at 17:46
  • I updated my question. Thank you for your comment. – byf-ferdy Oct 20 '13 at 21:59
  • apt-cache policy is telling you that you are not using the PPA for Gnome 3. I don't know if it's enough to fix your issue, but please try sudo add-apt-repository ppa:gnome3-team/gnome3 and then perform the upgrades. – Andrea Corbellini Oct 21 '13 at 20:19
  • It actually did the trick. I added the new repository, removed the version 2.0.4.2 of gir1.2-javascriptcoregtk-3.0 and ran apt-get install software-center. Now the dependencies are fine I think. Add this as an answer and I'll accept it. – byf-ferdy Oct 21 '13 at 20:28
0

The output of apt-get policy is telling you that gir1.2-javascriptcoregtk-3.0 is locally installed and does not come from a PPA:

gir1.2-javascriptcoregtk-3.0:
...
Version table:
*** 2.0.4-2~ubuntu13.04.1 0
    100 /var/lib/dpkg/status

This means that your system has no access to the whole set of packages offered by the Gnome 3 PPA. This may cause of many problems, including dependency problems.

Re-add the PPA with this command:

sudo add-apt-repository ppa:gnome3-team/gnome3

Then update and upgrade your system.

  • actually. The dependencies issue was fixed. But unfortunately the software-center keeps crashing. I'll create a new issue for that. – byf-ferdy Oct 21 '13 at 20:35
0

FIRST: run sudo apt-get update.
SECOND: the fastest solution is to install aptitude with sudo apt-get install aptitude and run it: it will find the conflict and propose a solution if you press "!" (watch the red horizontal line in the bottom of the aptitude console interface).
Select a solution (any solution which doesn't remove a big number or packets or a kernel should be OK), press G to apply it.
After that exit form aptitude and run sudo apt-get dist-upgrade to do a good update and re-check for problems.
Don't remove a kernel or the kernel headers (watch the description of the "linux" packages).
THIRD: After a reboot (superfluous but...) try to install Ubuntu Software Center.
Hope you'll solve. (arrow up if you solve, comment here to ask more questions on the topic)

  • 1
    why was this voted down? is there anything I should keep in mind that was not mentioned here? – byf-ferdy Oct 20 '13 at 21:51
  • I tried it, but Synaptic cannot fix my broken dependencies. – byf-ferdy Oct 21 '13 at 19:14
  • byf-ferdy: Synaptic will not fix your dependencies, aptitude (run it from the console) will, because it can offer you multiple choices. Before doing anything run sudo apt-get update to update your apt package lists. Please, vote up if this answer is useful. – Lorenzo Ancora Oct 22 '13 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.