3

I am running xubuntu 13.10 on a Lenovo ThinkPad X1 Carbon. It works very well, except the behaviour of my clickpad (touchpad where the buttons are built into the surface) makes it essentially unusable.

The default behaviour means that the whole area of the clickpad moves the mouse cursor, so that when I try and click anything, the mouse will move around slightly and I will miss my target.

After googling around, I saw suggestions suggesting that I should modify my /etc/X11/xorg.d/50-synaptics file (man) so that the AreaBottomEdge option is set to the height of the button area on my clickpad.

This worked in that it prevented the mouse from moving when I touch the clickable area, but it now does not allow me to move the mouse with another finger while holding the left click button down, so I cannot do selections/dragging/etc.

What I am after is configuration settings (or a different driver) that will turn off mouse movement over the clickable area of the clickpad, but still allow me to move the mouse while another finger is resting on, or clicking down on the clickable area. Essentially I want to make the clickable areas act like real buttons.

Thank you.

2
  • I have the same problem with my E540, have you found a solution?
    – wasp256
    Commented Jan 21, 2014 at 20:16
  • I managed to get something that tolerably works by replacing the default driver with xf86-input-mtrack. I had to spend a while changing the config to get something that was reasonable; even then, I haven't been able to get right-click working properly. Commented Jan 25, 2014 at 18:34

1 Answer 1

1

Try editing your /etc/X11/xorg.conf.d/50-synaptics.conf and adding this:

Option "SoftButtonAreas" "RBL RBR RBT RBB MBL MBR MBT MBB"
  • RBL is Right Button Left,
  • RBR is Right Button Right,
  • RBT is Right Button Top,
  • RBB is Right Button Bottom,
  • MBL is Middle Button Left,
  • MBR is Middle Button Right,
  • MBT is Middle Button Top,
  • MBB is Middle Button Bottom.

This defines the area of the clickpad where the touching clicks do not move the cursor. Maybe this didn't work way back then.

My ELAN1300:00 clickpad has these numbers where the middle button is from 40% to 60% of the touchpad width:

Option "SoftButtonAreas" "1924 0 1600 0 1379 1923 1600 0"

There can also be % values instead of touchpad coordinates:

Option "SoftButtonAreas" "1924 0 90% 0 1379 1923 90% 0"

This says the bottom 10% of the touchpad is reserved for the Soft Buttons and a touch will not move the cursor when beginning in that area. The /var/log/Xorg.0.log should show the final numbers used by the Xserver after interpreting the config file.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .