I decided to install Ubuntu 12.04 LTS second system with windows 7, UEFI. Made a LiveUSB, downloaded, started the installation.

The installer showed four sections, one for efi already existed (windows loader seems named, 100 MB), the other three, ntfs. One of them I erased (of course, partition with windows I saved), and created two partitions - swap and /. The installation was successful, no errors. But after the reboot comes to grub, the choice of Windows 7 again returns to the grub, when choosing Ubuntu - gives black screen with error:

[1.310472] Kernel panic - not syncing: No init found. Try passing init = option to kernel. See Linux Documentation / init.txt for guidance.

Besides, now will not ship LiveUSB.

  • Maybe this guide can help you? – MadMike Oct 20 '13 at 15:16

Please fix the bootsector of your sda1 partition this way: https://help.ubuntu.com/community/BootSectorFix

This should fix your Windows error.

  • Thanks, yesterday I already fixed windows error with boot-repair – MZHI Oct 21 '13 at 5:48

I had the same problem when I installed Ubuntu 13.10 alongside Windows 8. It turned out that the problem was UNetbootin (the LiveUSB image), which I had created on Fedora. Once I created a LiveUSB from Windows using http://www.pendrivelinux.com/ and reinstalled Ubuntu, everything worked fine.


Your Windows boot error sounds like you ran Boot Repair on the computer some time ago, then subsequently re-installed GRUB. Up to a couple of months ago, Boot Repair was aggressive in renaming Microsoft's boot loader (bootmgfw.efi) and replacing it with another copy of GRUB, which would create the problem you describe. If I'm right, re-running Boot Repair and using the Advanced option to restore backed-up files may fix that part of the problem. You'll need to boot from an emergency/live CD to do this, of course.

Your Linux problem is more obscure. It may indicate a problem in the initial RAM disk (initrd) or on your installed system. Either is a very strange error, since this is very basic stuff that should not be causing problems. A problem here is most likely a symptom of some other problem, like a disk that's full or otherwise failing. Perhaps more clues would be present in the Boot Repair logs; when you run that program, it spits back a URL with logs. Post that URL here for us to see.

  • Thanks a lot for detailed answer! Here are the logs from boot-repair paste.ubuntu.com/6272359 – MZHI Oct 20 '13 at 19:26
  • I can still add (may be it is important for finding solution), that before installing ubuntu, I used your program FixParts, because installer didn't see windows partitions. – MZHI Oct 20 '13 at 19:37
  • After repair: paste.ubuntu.com/6272840 – MZHI Oct 20 '13 at 20:49
  • LovinBuntu's suggestion for fixing your Windows partition (/dev/sda1) sounds promising to me. I'm still not sure exactly what's causing the Linux problem. Since you've just installed, the cowardly suggestion to re-install from scratch may be the easiest solution -- but do not install GRUB in /dev/sda1! GRUB needs to go in the MBR (/dev/sda), or occasionally in a Linux partition. – Rod Smith Oct 20 '13 at 22:45
  • If I understand correctly from logs paste.ubuntu.com/6272840, now I have two grubs, on /dev/sda1/ and /dev/sda/ ? That is, boot-repair installed grub on /dev/sda/ but didn't delete from /dev/sda1/ ? P.s. windows now ships normal – MZHI Oct 21 '13 at 5:59

In my case, the solution to this error turned out to be disabling Secure Boot in the BIOS. Initially, I was not able to boot from my hard drive or from a Live DVD. However, I could boot from a live USB. Different distros behaved a little differently, but none would fully boot and no solutions others had posted worked for me. This was a Lenovo x201 laptop, after replacing Windows 7 with Ubuntu.


...same case. I installed from USB stick and that was the reason: while writing the image with Universal-USB-Installer to the stick (from Win 7) my Virus scanner blocked writing of a file named 'autorun'. Adjusting Virus scanner to let 'autorun' pass and everything went fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.