After typing my password it starts to load but then comes right back to login screen.

I tried Ctrl+Alt+F_ but it doesn't work too, the screen gets black and after a while returns to the login screen.

It seems related to the ATI driver that I installed, if I could somehow remove it should be worth trying.

But without being able to log in or reach the shell how will I do it?

Re-installing the system is not an option for me.


I had a very similar problem a few days ago. It may not work for you, but since nobody else has answered yet, I thought it was worth a shot. I think what you need to do is have Ubuntu regenerate the .Xauthority file which is a file in your home directory.

This is how I did it:

  1. At the login prompt change to the non-graphical mode by pressing: Ctrl+Alt+F1
  2. Make a backup of your .Xauthority file:

    sudo mv .Xauthority .Xauthority.backup
  3. Switch back to the login screen: Ctrl+Alt+F7 and log in.

This should regenerate the file and break the loop.

  • I just ran across the same problem on a Macbook Pro with ATI graphics. The .Xauthority file in my user directory belonged to root. Deleting the file solved my problem. – Torsten Jan 31 '14 at 20:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.