Today I upgraded from Ubuntu 12.04 to Ubuntu 13.10. I am not able to watch any videos in Amazon Prime Instant Video. I am getting this message:

An error occurred and your player could not be updated.  
This is likely because your Flash Player or Browser needs to be updated.
This update is required to play back this video.
  • Simply update the flash-plugin of your browser of choice and/or a new flash-version if available through 'Update-Manager'.
    – v2r
    Oct 20, 2013 at 12:00
  • I am using Firefox and I have Flash player version "" installed. I tried same thing in Chromium browser and I am getting same error message. Oct 20, 2013 at 16:32
  • I too have a problem where Amazon prime will not play in Ubuntu 12.04 using Firefox nor Chrome. In firefox shockwave flash was updated on 5/8/2014 to version May 27, 2014 at 2:09
  • @v2r The problem on Ubuntu 13.10 or higher (I am running 14.04) is not an obsolete flash player.
    – DBS
    Jun 2, 2014 at 4:08

5 Answers 5


Ubuntu 13.10 does not have HAL in it's repos, so you might be able to get it at mjblenner's ppa. I have not tried to get Amazon Instant Video to run yet, but thought I would throw this out here anyway.

sudo add-apt-repository ppa:mjblenner/ppa-hal
sudo apt-get update
sudo apt-get install hal


The following extra packages will be installed:
  hal-info libhal-storage1 libhal1
The following NEW packages will be installed:
  hal hal-info libhal-storage1 libhal1

Simply close Firefox. Reopen it. And, you're done!

Another hal-related option (should purge previous, if installed, but I could not get repo below to work with 15.04 Vivid):

sudo add-apt-repository ppa:mjblenner/hal-flash ## Trusty & Utopic
sudo apt-get update
sudo apt-get install libhal1-flash

Another thing to try would be to install Firefox through PlayonLinux, including Silverlight and Adobe Flash. PlayonLinux seems to be up to 14.04 Trusty Tahr right now.(Aug2015)

  • 4
    Thanks! This worked. However I had to run sudo apt-get install hal again and rm -rf ~/.adobe Dec 24, 2013 at 2:31
  • 1
    Full instructions that worked for me on 13.10 are here: ubuntuforums.org/… Mar 21, 2014 at 12:29
  • 1
    This worked for me!
    – DBS
    Jun 2, 2014 at 4:08
  • 3
    This works on 14.04 Trusty Tahr too, by the way.
    – Kazark
    Oct 7, 2014 at 0:03
  • 1
    Still works on 15.04 :-)
    – anps
    Jun 24, 2015 at 11:15

I had this same problem. For some reason libhal is not in the repos!!! So, you must follow the solutions on http://ubuntuforums.org/showthread.php?t=2144347&p=12811464#post12811464 Follow them, and make sure you have spaces in the commands (i.e. sudo(SPACE)mkdir(SPACE) && rm(SPACE)-rf(SPACE)fileName)

Here is what the site says (with some minor editing):

You can get these sites (websites that use Digital Rights Management, like Amazon) working in Ubuntu but it is gettting harder and harder e.g. the 'hal' packages have now been deleted from the ubuntu 13.10 repos !

here is what you need to do:

  1. Make sure you are using firefox or chromium. If you are using chrome make sure the pepper flash plugin is turned off
  2. if using ubuntu version 13.10 must download and install these raring(13.04) .debs because they have been deleted from the 13.10 repos:

  3. Once the debs are installed, then patch hal by executing the following shell commands: (this will make the appropriate directories, and start hald in the backgound)

    sudo mkdir /etc/hal/fdi/preprobe
    sudo mkdir /etc/hal/fdi/information
    /usr/sbin/hald --daemon=yes --verbose=yes
  4. close the browser and clear the Adobe Access directories by executing the following shell commands: (rm -rf removes all files, recursively (r), which means it includes all subdirectories and forces(f) them to be removed)

    rm -rf ~/.adobe
  5. need to reset licence files (this is critical too !): http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager08.html

  6. test via http://drmtest2.adobe.com:8080/SVP/SampleVideoPlayer_FP.html#

  7. paste in this video url: http://drmtest2.adobe.com:8080/Content/anonymous.f4v

Hopefully hal will be restored to the ubuntu repos.

  • 1
    I followed these instructions with Ubuntu 13.10 and using Chrome, and Amazon Instant Video still does not work. However, it does work on Firefox.
    – dkaczynski
    Dec 25, 2013 at 16:12
  • The linked .deb files do not exist anymore...
    – m13r
    Feb 7, 2015 at 10:43
  • chmod 777 ~/.adobe/Flash_Player/* is probably all you really need to do.
    – jarederaj
    Feb 13, 2015 at 21:08

HAL is currently deprecated, but Adobe Flash needs it for playing DRM content (for whatever reason). Fortunately there's a shim that provides just enough HAL API for Flash to work; it's available at https://github.com/cshorler/hal-flash — packages for Ubuntu and other systems can be found at https://build.opensuse.org/project/repositories/home:chorler:branches:devel:openSUSE:Factory

I haven't tried it on Ubuntu, but I can confirm that on Gentoo installing this makes Amazon Prime work.

  • 1
    This is the only method that worked for me on Ubuntu 13.10 x64 with Firefox. Thanks! Mar 21, 2014 at 2:24
  • 1
    – noobninja
    Aug 22, 2015 at 3:47

In Firefox (Menubar) go to 'Tools > Add-ons > Plugins > Check to see if your plugins are up to date', like suggested in the screenshot.

enter image description here This will open up a new tab, looking like this: enter image description here

Now you know, that your Shockwave Flash-plugin is (most likely) out of date!
To fix this i suggest, that you first install Ubuntu restricted extras from within Software Center (if you haven't already done so). Make sure to tick the box Adobe Flash plugin. You can also mark the others too! Or install via shell:

sudo apt-get install ubuntu-restricted-extras

I checked Adobe FLash Player Help HP and v. is the latest available/supported so far. I guess there is not much you can do right now, but wait for a new release!

Quote: 3. Find the latest Flash Player version available for your operating system:

Mozilla, Firefox, SeaMonkey (Flash Player 11.2 is the last supported Flash Player version for Linux. Adobe will continue to provide security updates.)

enter image description here

  • I installed Ubuntu restricted extras and currently I have version Flash version "". But even after updating, Firefox shows Shockwave Flash is Vulnerable. Amazon prime used to work without issues in 12.04 but now it is failing. Oct 21, 2013 at 1:58

Managed to get the amazon videos to play with pipelight. basically, you use silver light instead of adobe flash to play the videos. It seems to have worked for my ubuntu 12.04 x64 (I haven't watched a whole movie yet).

this is the tutorial I followed: http://www.webupd8.org/2013/08/pipelight-use-silverlight-in-your-linux.html

the other thing I found is with chrome, I had to use the UA spoofer set as firefox 15 in order to work (as listed at the bottom or the link). downside is I can't just tab between a googetalk call and watch amazon prime video at the same time with the UA spoofed.

  • You can also enable the Windows version of Flash Player (and remove the native version, if desired) using pipelight-plugin --enable flash. Please note, you will have repeat this for every user on your system, unless you run the command as root (the latter will install Flash for Windows on all users). Feb 12, 2014 at 4:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.