11

After upgrading to 13.10, ibus (which had its own little icon in the task bar) fails to load. Instead I get a little icon, whose preferences direct me to "Text Entry". When I try open the "Input Method" from the dash, it says:

Current configuration for the input method:

  • Active configuration: missing (normally missing)
  • Automatic configuration: ibus (normally ibus or fcitx or uim)
  • Number of valid choices: 2 (normally 1)

The configuration set by im-config is activated by re-starting X. Explicit selection is not required to enable the automatic configuration if the active one is default/auto/cjkv/missing.

Available input methods: ibus xim

Unless you really need them all, please make sure to install only one input method tool.

When searching for xim in the package manager I get no installed hits.

How can I get rid of xim and get ibus again? (I can add my input method, Anthy, via this new little icon, but I use a different keyboard layout, also to enter Japanese text.)

1
  • Earthliŋ, were you able to remove XIM? – Suncatcher May 20 '18 at 15:06
10

In short, you don't want to use the im-config utility to change input methods.

Set the default input method from System Settings >> Language Support >> Default input method

After that, both input method setup and keyboard layout setup are now in System Settings >> Text Entry.

These changes seem to have caused some problems for Ibus. Assuming you have ibus-anthy installed, if you don't see Anthy in the list of input methods in Text Entry, go ahead and reinstall Ibus with sudo apt-get install --reinstall ibus and reboot.

I had similar problems but Anthy is now working fine after reinstalling Ibus.

Anthy has it's own setting for the keyboard layout that it uses.

1) In Text Entry, make sure your German keyboard is at the top of the list of input methods. This will make it the system default keyboard.

2) Highlight Anthy and click the the toolbox/configuration button that appears down by the keyboard button. This opens the Anthy settings.

3) Go to the tab called Typing Method. Change the keyboard layout to Default (which will now be German).

4) Be sure to hit the Apply button, before hitting OK.

4
  • I feel like this could be the answer to my question, but "Text Entry" only lists "Input sources", no matter what keyboard input method system (default, Ibus, none) I choose from "Language support". I can choose Anthy in "Text Entry" but it gives me Anthy not with my keyboard layout, but with something like US keyboard (although my hardware is German). – Earthliŋ Oct 20 '13 at 1:06
  • My apologies, I missed your mention of needing to use a non-US keyboard. I've edited the answer. – chaskes Oct 20 '13 at 1:40
  • 1
    Thank you very much for the explanation, finally I can type without worrying about different layouts. – Donarsson Oct 29 '13 at 10:40
  • Reinstalling ibus solved my strange keyboard issue with x2go + Ubuntu 14.04 + LXDE. Thanks! – Cameron Taggart May 25 '16 at 23:12
0

Addition to chaskes great answer:

If the installation of the missing language support fails, try to open the dialog with root permission:

$ sudo gnome-language-selector

(I'm using i3, maybe it does not affect Gnome user. Opening language support via the gnome-panel, lead to errors during the installation. I don't know why it didn't open a dialog to ask for root permission. Maybe a bug.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.