Unfortunately in Ubuntu 13.10 there is no tray icon and whitelisting is removed.

The older solutions do not work for me, e.g. I get the message: No such schema 'com.canonical.Unity.Panel' when I try to use the command:

gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"  

How can I get tray icons back (for applications that put an icon in the tray (like TrueCrypt, Pidgin, Aqualung, gnome-system-monitor and so many more) in Unity?

The most annoying thing is that the user loses control over applications which cannot themselves detect that they have no tray icon (e.g.: gnome-system-monitor, TrueCrypt...). At least Aqualung sends a message about being unable to put an icon in the system tray!

  • 2
    Alas, this is Mark Shuttleworth's idea, and it will not be fixed. You can see the original "bug". Please vote for the bug asking to have it fixed (click the green writing at the top of the page). There is a PPA for TrueCrypt, which Stefan Sundin has generously created, because the TrueCrypt creator is not interested in changing TrueCrypt to cater for Mark's whims. Type this command in a terminal, and then update: sudo add-apt-repository ppa:stefansundin/truecrypt – Paddy Landau Oct 29 '13 at 16:47

I really don't recommend using my sacy-tests PPA 'blindly' (mentioned in the answers by @alwaysask and @tolima). Because it contains changes to many packages, some quite specific. One should take the time to read the descriptions to see if any or all these changes are wanted.

(When using add-apt-repository you are given the opportunity to review them ...)

So because some just want to re-enable the whitelist and may not appreciate or find the other changes I use suitable, I have set up a standalone PPA for just re-enabling the whitelist for unity in Ubuntu saucy, if still viable will add trusty down the road:


  • 7
    Now - Launchpad.net: "Lost something? This page does not exist, or you may not have permission to see it." – Orion Sep 25 '14 at 18:37

installing libapindicator1 worked for me. Logout and login The original post is here

sudo apt-get install libappindicator1

Note: Works well with Dropbox and possibly some more apps i.e. Skype, but not with Pidgin and many others.

  • This worked for me on Ubuntu 16.04 (xenial) for Slack, but not for Skype. – Zoltán Apr 29 '16 at 11:56
sudo add-apt-repository ppa:mc3man/sacy-tests
sudo apt-get update
sudo apt-get upgrade
gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"

then restart

  • Yes, it is working for me at all! But unfortunately I have got back a bug again with compiz/hotcorners... I'm using four virtual desktops, and changing between with mouse moving to top-right hotcorner. Also using Unity-tweak-tool for this setting. And now, after this patch I have the same bug - hotcorner does not work - as were in 13.04. When I start my computer I always need to switch off and on again the hotcorners with Unity-tweak-tool for working again... Maybe connection between the two bugs? – Silken Oct 26 '13 at 21:10
  • 1
    See my answer below concerning this ppa – doug Nov 1 '13 at 2:34

Try this plugin http://www.webupd8.org/2014/01/pidgin-indicator-ubuntu-appindicator.html ... To install Pidgin Indicator plugin in Ubuntu, use the following commands:

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install pidgin-indicator

If you don't want to add the main WebUpd8 PPA, you can download the Pidgin Indicator deb from http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu/pool/main/p/pidgin-indicator/ and install it manually.

  • 1
    This worked for me for Skype on Ubuntu 16.10 after sudo apt-get install sni-qt:i386 and sudo apt-get install libappindicator1 – Elder Geek Nov 11 '16 at 20:45

You can add this ppa: https://launchpad.net/~mc3man/+archive/sacy-tests which brings back the systray whitelisting. Then (update will complain about signature):

sudo apt-get update
sudo apt-get upgrade
gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"
  • See this other answer by @doug for a discussion on using this PPA, and a better approach when the task is getting back whitelisting only. – tanius Feb 17 '14 at 17:02

Updated instructions using doug's standalone PPA:

sudo apt-add-repository ppa:mc3man/systray-white
sudo apt-get update
sudo apt-get upgrade
gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"

then restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.