I updated my kubuntu to 13.10 today and my virtualhosts that worked perfectly before are no longer working.

the s2ensite and a2dissite commands claim "site xxxxxx does not exists" even the files are in sites-aviable and were in sites-enabled I tryed to remove them from sites-enabled and then enable them again, but still apache claims they would not exists.

Here is one of my virtualhosts. They are basically all like this.

<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    ServerName expsite.local

    DocumentRoot /var/www/expsite/htdocs
    <Directory />
        Options FollowSymLinks
        AllowOverride None
    <Directory /var/www/expsite/htdocs/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride FileInfo
        Order allow,deny
        allow from all

#   ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
#   <Directory "/usr/lib/cgi-bin">
#       AllowOverride None
#       Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
#       Order allow,deny
#       Allow from all
#   </Directory>

        CustomLog /var/www/expsite/logs/access.log combined
        ErrorLog /var/www/expsite/logs/error.log
        LogLevel warn

#    Alias /doc/ "/usr/share/doc/"
#    <Directory "/usr/share/doc/">
#        Options Indexes MultiViews FollowSymLinks
#        AllowOverride None
#        Order deny,allow
#        Deny from all
#        Allow from ::1/128
#    </Directory>


The 000-default is working and I can enable and disable it.


Ubuntu 13.10 and variants have moved to Apache 2.4 and Apache 2.4 wants enabled virtual host config files to end in .conf by default. See here:


I just renamed my vhost config files to end in .conf and everything worked!

  • This issue took hours on 2016 after an upgrade. Thanks – Rodrigo May 22 '16 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.