11

I just did a fresh install of Ubuntu 13.10 64bit, and it says that I have 2 monitors, when I actually only have one

enter image description here

I have a Dell XPS 15 with Nvidia graphics card if that helps in anyway

  • Your Laptop Have Or Desktop have DVI port ? or HDMI port ? if so it will be there its not a issue – Babin Lonston Oct 24 '13 at 12:10
18

I am not an expert but I had the same problem. I have finally find the solution on this forum (here).

First, enter xrandr in your terminal. You will see that there are several outputs which are connected. The LVDS1 is your laptop's screen. Normally, there is another outpout called VGA-1 orVGA-2 which is also connected. You have to note the name of this output.

Then, edit your grub with gksudo gedit /etc/default/grub and add video=VGA-1:d (VGA-1 is the name of the wrong output) in the GRUB_CMDLINE_LINUX line (you must have something like GRUB_CMDLINE_LINUX="video=VGA-1:d").

  • If your output is called like VGA-1-1, set video=VGA-1:d (setting video=VGA-1-1:d won't work).

  • If your output is called like VGA-1-2, set video=VGA-2:d (setting video=VGA-1-2:d or video=VGA-1:d does not seem to work, although one may still try them out separately to be certain).

Then update your grub with sudo update-grub and reboot.

| improve this answer | |
  • 1
    Thanks that worked great :D just changed it to 'GRUB_CMDLINE_LINUX="video=VGA-2:d"', but the weird thing is my laptop doesn't even have VGA :/ – Jeggy Oct 24 '13 at 21:15
  • Just a minor correction, it should read GRUB_CMDLINE_LINUX="video=VGA-1:d" (there is an equal sign after GRUB_CMDLINE_LINUX) – hadi Feb 7 '14 at 19:54
  • I have LVDS1 and LVDS1-1, but your solution sis not work for me ... – Augustin Riedinger Feb 18 '14 at 0:25
1

See my suggestion in Mouse cursor flickering with ubuntu 13.10. Installing Bumblebee got rid of the unwanted display and flickering mouse cursor. xrandr -q also displayed only the correct displays whereas before installing BB, it showed the built-in display as well as an extra VGA-1-1 as being connected.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.