I have some problems on my Asus notebook since I upgraded to Ubuntu 13.10:

  • Networking (wifi and lan) won't work after resume from suspend. I've seen many posts about this but they wouldn't work for me (adding iwlwifi to the list of loaded modules).

I couldn't find anything on that problem, and I don’t know where to look at to solve that. Is there any information I can add?

closed as off-topic by Jorge Castro, Braiam, Warren Hill, Eric Carvalho, user117103 Oct 20 '13 at 15:57

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Jorge Castro, Braiam, Warren Hill, Eric Carvalho, guntbert
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1) Here is the syslog generated when I activate the wifi before a suspend (works) pastebin.com/KQq3DqkW ; and here is the syslog generated when I try activating wifi after a suspend (doesn't work) pastebin.com/7KrAnUnf . – Michael-A-D Oct 19 '13 at 21:18
  • Looking at the answers this is a bug. – Braiam Oct 20 '13 at 1:06
  • The best way to add additional information to your question is by editing it, with the edit button. It is better visible that way, and comments are mainly for secondary, temporary purposes. Comments are removed under a variety of circumstances. Anything important to your question should be in the question itself. – guntbert Oct 20 '13 at 15:56
  • Also see askubuntu.com/questions/365441/… – belacqua May 25 '14 at 3:08
  • 1
    Bug #1286552 - No wifi after suspend. – bain Aug 3 '14 at 14:53

Sounds like bug #1234469: Network does not come up after resuming from suspend.

The workaround is to run:

sudo nmcli nm sleep false

This workaround uses the nmcli to change the sleep state of the nm.

nmcli is the Network Manager command-line interface
nm is the Network Manager

  • This helped me a bit on 12.04 Xubuntu, after this and manual suspend, the card start blinking again, but finally no success on getting it worked. Only wifi is working, the RJ45 eth0 jammed after resiming from suspend. – Dee Nov 15 '13 at 11:59
  • That was fast. Is it permanent? – PyRulez Jun 30 '14 at 1:12

That workaround did not work for me. However this worked:

I have still no solution but I have found a workaround:

Create a new shellscript named hibernate.sh. Open it with gedit and paste the following code:

gnome-screensaver-command -l dbus-send --system --print-reply \
    --dest="org.freedesktop.UPower" \
    /org/freedesktop/UPower \

Save it and make it executable. If you want you can create a .desktop file for it. When you run this script it will send your pc into hibernate-mode including the lockscreen. When you wake your pc now networking works. When you use sleep-mode or hibernate-mode the normal way it doesn't.

Thanks to Christopher Paul over here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1212199

Note that you'll need to restart your system once after that (if your network was out due to a suspend when you did the script). Then it works fine.

Also note this script sends your pc to suspend, not to hibernate (the name could be confusing).

Not the answer you're looking for? Browse other questions tagged or ask your own question.