2

I have a laptop that's currently configured as a dual-boot. The problem: I cannot connect to the Internet in the home wireless network through Ubuntu in the apartment where I currently live. The strange part: I can connect to it just fine through Windows (as right now), and I can use the Internet through Ubuntu on this computer with all the other wireless networks I have tried. The problem is only with this particular combination.

The only possible explanations I can think of are either that this network is WPS, or that it's a driver problem--Vodafone router. The router 'sees' the computer--and it says it's connected; however, I keep getting prompted for a password, and I enter the key that works with Windows, but in Ubuntu it just keeps asking for it repeatedly, and I can't access the Internet.

I don't have an ethernet cable at the moment, but if someone would be so kind as to ask me questions I will gladly answer, and if you have suggestions, I will do them--the only thing is, I am subletting this apartment from someone who is away on vacation, so I don't want to screw with the router settings unless I know what I'm doing!
- I do not have Wicd
- Yes, I have the router's information (key works in Windows)
- Feedback of lshw says that the wireless card is Ultimate N Wifi Link 5300, vendor: Intel Corporation, physical id: 0 ,etc.
The first two commands I was told to try work OK, but when I typed sudo ifconfig wlan0 essid ..... I got back 'essid: Unknown host'
Would my question be better on the Ubuntu forums than here on AU?

  • Well there's not enough information on your question. First, did you check additional drivers? Softwares & Updates > Additional Drivers > If anything is listed related to wireless install it(using a wired connection). If this does not help, please list your wireless card make & model. – simbadub23 Oct 19 '13 at 17:31
  • I don't think the issue is drivers related to the router, more possibly your wifi card. Does Ubuntu see the wireless network? Does Ubuntu detect your wifi card? Do you know the information about the router, such as the password and such? (Don't tell us the info, just let us know if you do) – Thomas Ward Oct 19 '13 at 17:35
  • I suggest another title for this question. As Opening Post shows, Ubuntu can connect to the internet through wifi, but only a partical wireless wifirouter gives (authentication)problem. – user85164 Oct 19 '13 at 21:07
  • Can you please add the driver in use e.g. 'iwlwifi' to your question? It should be part of the lshw output. Sometimes the Intel wireless drivers work fine with wireless-g networks but have trouble staying connected to wireless-n networks - you can test if that's the issue either by switching your router to 'g-only' mode, or by issuing terminal commands sudo modprobe -rf iwlwifi && sudo modprobe -v iwlwifi 11n_disable=1 (obviously this assumes your driver really is iwlwifi). If that works it can be made persistent via a conf file. – steeldriver Oct 19 '13 at 21:08
1

Are u using Wicd per case on Ubuntu? Back in time I were testing wicd with NM still installed and had similar issue. Fix was easy, removing wicd and keeping NM, the two programs were in conflict and could not read my password. however try to connect through CLI

this command to enable device
sudo ifconfig wlan0 up
if no any feedback it means no problem

than make sure network is available with
sudo iwlist wlan0 scan
this should list all available networks

than
sudo iwconfig wlan0 essid NETWORK key WIFI_KEY
NETWORK is your ESSID and WIFI_KEY is password

Get IP address by dhclient.
sudo dhclient wlan0
if no any feedback it means no problem and you should be up and running.

Update Please comment under specific answer its just easier to follow up click here to see how this site work. However if returned unknow host on sudo iwconfig wlan0 essid NETWORK key WIFI_KEY command most likely you are using wrong network ID, make sure its right (copy it from results of sudo iwlist wlan0 scan as there it will be listed and make sure you aren't using quotation marks).

  • Thank you. Something finally worked, I am typing to you now in Ubuntu. The strange thing is, from the terminal, I kept getting 'SET failed, invalid argument,' whether I used the right or wrong key. But then, when I typed some other strange key that I only just found from poking around the network's properties in Windows, into the dialog box that kept popping up, instead of setting it through the terminal, suddenly the connection was established. Strange, and I'm afraid it will stop working again. If it does, I will update again. – laur34 Oct 20 '13 at 13:18
  • Good it worked, best thing is to save the keys and essid that worked. – danijelc Oct 20 '13 at 13:34
  • all these commands ran fine for me but when i did sudo dhclient wlan0 it just sat loading with no response for a long, long time. I also have an Ubuntu/Windows 7 laptop and internet works fine in Windows but not Ubuntu – khaverim Dec 5 '14 at 2:59
  • There shouldn't be any response to that comand. Not sure what you mean. – danijelc Dec 6 '14 at 8:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.