I upgraded my Ubuntu to 13.10 and now I can't hear any sounds.

I checked on alsamixer that voices are on. For example, I can't hear any Youtube videos.

  • 1
    Not sure why someone protected this question - it an ongoing issue affecting MANY people - point of StackExchange is to float to top in-demand questions/answers, not shunt out inputs – Scott Stensland Oct 30 '13 at 23:49
  • This question is a mess. It offers no details about what could be get wrong, the accepted answer is "wait" until upstream fix their stuff. @ScottStensland I'm not even sure why this wasn't closed in the first place. – Braiam Jan 4 '14 at 11:52

I also lost my sound when upgrading to 13.10.

To fix it, I ran this in Terminal (Ctrl+Alt+T):

sudo alsa force-reload

Did a restart, and everything was working perfectly.

  • 4
    I tried this but it won't solve the problem on my computer. – guest Oct 22 '13 at 16:23
  • 3
    did not work for me either – vegard torvund Oct 26 '13 at 21:09
  • 1
    i tried this and the other answer i commented upon. worked for me. – user128334 Dec 3 '13 at 23:04

I got mine working when I looked at this document:

The issue was that I needed to add some permissions to my user. Easy to tell if that's the fix because aplay -l will say no soundcards but sudo aplay -l lists some. This was my fix:

sudo usermod -aG audio,video,pulse,pulse-access frew
  • 1
    i tried this and the other answer i commented upon. worked for me. – user128334 Dec 3 '13 at 23:05

this worked for me How do I change which audio jacks are used for input and output? or make this in to a hda-mods.py and put it in /etc folder because on sudo python run.py all the sound muted just unmute the sound then save it

If you want to keep your changes permanently, don't close HDA Analyzer yet. Instead, click "Exp" (Export) at the bottom-left and use Save As to write the python script to a file. Now copy that file to something like /etc/hda-mods.py and edit /etc/rc.local as root (e.g. using gksudo gedit /etc/rc.local) and add the line python /etc/hda-mods.py right before the exit 0 line, then save it and reboot. Your changes should survive.

#!/usr/bin/env python

import os
import struct
from fcntl import ioctl

def __ioctl_val(val):
  # workaround for OverFlow bug in python 2.4
  if val & 0x80000000:
    return -((val^0xffffffff)+1)
  return val

IOCTL_INFO = __ioctl_val(0x80dc4801)
IOCTL_PVERSION = __ioctl_val(0x80044810)
IOCTL_VERB_WRITE = __ioctl_val(0xc0084811)

def set(nid, verb, param):
  verb = (nid << 24) | (verb << 8) | param
  res = ioctl(FD, IOCTL_VERB_WRITE, struct.pack('II', verb, 0))  

FD = os.open("/dev/snd/hwC0D0", os.O_RDONLY)
info = struct.pack('Ii64s80si64s', 0, 0, '', '', 0, '')
res = ioctl(FD, IOCTL_INFO, info)
name = struct.unpack('Ii64s80si64s', res)[3]
if not name.startswith('HDA Codec'):
  raise IOError, "unknown HDA hwdep interface"
res = ioctl(FD, IOCTL_PVERSION, struct.pack('I', 0))
version = struct.unpack('I', res)
if version < 0x00010000:    # 1.0.0
  raise IOError, "unknown HDA hwdep version"

# initialization sequence starts here...

set(0x0e, 0x300, 0x6080) # 0x0e036080 (SET_AMP_GAIN_MUTE)


Not the answer you're looking for? Browse other questions tagged or ask your own question.