12

I am trying to run gnome-fallback.desktop under VncServer.

After upgrading to 13.10, my VNC no longer works - it just shows an empty terminal window, with no session.

These are the sessions that I have installed:

$ ls /usr/share/xsessions/
gnome.desktop                  gnome-fallback.desktop  xfce.desktop
gnome-fallback-compiz.desktop  ubuntu.desktop

And this is the contents of my ~/.vnc/xstartup file , which is pointing to gnome-fallback.desktop as far as I can tell:

#!/bin/sh

# Uncomment the following two lines for normal desktop:
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
# exec /etc/X11/xinit/xinitrc
gnome-session --session=gnome-fallback.desktop &
#gnome-session --session=gdm-session &

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
x-window-manager &

This is the output of the log file in ~/.vnc/:

Xvnc Free Edition 4.1.1 - built Jan 14 2013 22:28:40
Copyright (C) 2002-2005 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
Underlying X server release 40300000, The XFree86 Project, Inc


Sat Oct 19 17:37:51 2013
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5901
 vncext:      created VNC server for screen 0
error opening security policy file /etc/X11/xserver/SecurityPolicy
Could not init font path element /usr/X11R6/lib/X11/fonts/Type1/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/misc/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/75dpi/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/100dpi/, removing from list!
Could not init font path element /usr/share/fonts/X11/75dpi/, removing from list!
Could not init font path element /usr/share/fonts/X11/100dpi/, removing from list!
Option "--login" is no longer supported in this version of gnome-terminal; you might want to create a profile with the desired setting, and use the new '--profile' option
gnome-session-is-accelerated: No composite extension.
gnome-session-check-accelerated: Helper exited with code 256
Window manager warning: Log level 32: could not find XKB extension.
gnome-session-is-accelerated: No composite extension.
gnome-session-check-accelerated: Helper exited with code 256

** (process:1602): WARNING **: software acceleration check failed: Child process exited with code 1

** (gnome-session:1602): CRITICAL **: We failed, but the fail whale is dead. Sorry....

It seems that gnome-fallback.desktop now requires accelerated graphics? Is this correct?

7

It kind of works if I start things manually that gnome-session used to start. Fonts don't seem to be set though.

~/.vnc/xstartup

#!/bin/sh

export XKL_XMODMAP_DISABLE=1
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS

gnome-panel &
gnome-settings-daemon &
metacity &
nautilus &
gnome-terminal &
| improve this answer | |
  • How do you start things manually? When do you run this script? – muzzamo Oct 27 '13 at 2:58
  • I meant manually in the sense that I'm starting things that gnome-session used to do. This is still just ~/.vnc/xstartup. – slow Oct 27 '13 at 12:00
  • 1
    This is more or less what I am doing, but I get strange behavior of the TAB key in this session... it acts more like alt-tab, switching to a different window. But I can use Ctrl+I to get a tab. – aap Dec 30 '13 at 2:21
  • Which VNC server are you using? I have found that tigervnc (downloaded from sourceforge) is the only one that doesn't suffer from having the super key stuck. – slow Dec 31 '13 at 23:54
  • Tried tightvnc and vnc4server. Worked around it by using openbox instead of metacity. Would have tried tiger if I found a ppa.. . But nice to know they fixed it. – aap Jan 28 '14 at 18:11
2

I had the exact same problem after the upgrade, I tried searching around for a possible solution, but I was unable to find anything relating to the software acceleration problem.

In the end I couldn't be arsed to dig around anymore, so I just went with xfce4 and now it's working perfectly fine again.

Here's my Xstartup:

#!/bin/sh
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
startxfce4 &

My guess is gnome-fallback might be broken, and defaults to gnome3 somehow, which actually requires acceleration in order to work.

Hope this helps you.

| improve this answer | |
  • I have also reverted to xfce. Unfortunately, the windows key seems to be stuck under VNC (applies to both xfce and gnome). unix.stackexchange.com/questions/58167/… – muzzamo Oct 21 '13 at 9:10
  • There's a solution for this, you just have to remove all the keyboard shortcuts that have <Special> in them, that you actually need to use. I had the same exact problem, so I just removed all the shortcuts that were bugging me. Who needs the Windows button in Linux anyway? :) – Alex Oct 21 '13 at 13:35
2

This is a (very disappointing) Gnome problem. The problem is over a year old and still present in a 14.04 LTS.

The solution of using --disable-acceleration-check from this thread did not work for me.

https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/1251281

Yep, as a workaround, xfce4 or fluxbox (run startfluxbox) will work.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.