1

I just upgraded from Ubuntu 13.04 to the latest release, saucy-salamander, also known as Ubuntu 13.10. I am facing problems with associating file types to applications. Instead of the traditional applications list that all the other versions of Ubuntu offered when a person is trying to associate a file to an application, Ubuntu 13.10 is giving me an option to search to the application executable.. which is rather frustrating.

enter image description here

How do i activate the old and traditional method whereby i have to chose an application directly without hunting down through the system for the executable...??

5
  • Can you try installing the apturl package (sudo apt-get install apturl). What type of file or link are you trying to open?
    – kiri
    Oct 18 '13 at 23:29
  • think you forgot to say that this is happening when you click on a special link inside a web browser Oct 18 '13 at 23:31
  • Minerz...already tried that, apt-url is already the latest version Oct 18 '13 at 23:46
  • The link is an apt:url type of link, that is supposed to redirect you to Ubuntu Software Center when you click on it Oct 18 '13 at 23:49
  • possible duplicate of Change all associations from gedit to another application
    – Anwar
    Jul 12 '15 at 18:19
2

I suggest Ubuntu-Tweak to configure the file associations, as Anwar Shah suggests here: Change all associations from gedit to another application.

First you must download the installer (a .deb file) from http://ubuntu-tweak.com/. Then open the file and install the program from Ubuntu Software Center. Finally, Open Ubuntu-Tweak an go to Admins -> File Type Manager.

At the list, look for your filetype and clic Edit -> Add to choose your custom application.

If you are trying to associate a Wine app (i. e. MS-Word to open .doc and .docx filetypes), you can add the application to the list if you edit the .desktop file located in ~/.local/share/applications/. Then, locate the "Exec=" parameter and, at the end of the line, add %U.

For MS-Word 2007:

gedit ~/.local/share/applications/wine/Programs/Microsoft\ Office/Microsoft\ Office\ Word\ 2007.desktop

At the end of "Exec=" line, add %U. My file looks like this now:

[Desktop Entry]

Name=Microsoft Office Word 2007 Exec=env WINEPREFIX="/home/goghard/.wine_Office2007" wine C:\\windows\\command\\start.exe /Unix /home/goghard/.wine_Office2007/dosdevices/c:/users/goghard/Start\ Menu/Programs/Microsoft\ Office/Microsoft\ Office\ Word\ 2007.lnk %U

Type=Application

StartupNotify=true

Comment=Create and edit professional-looking documents such as letters, papers, reports, and booklets by using Microsoft Office Word.

Icon=2C1E_wordicon.0

For more detailed info, look the answer of user24185 at: How to associate file types with wine in nautilus.

1

I think i finally found a way....after a long struggle.

When the popup shows, and there are no apps to choose, you just go into the filesystem and choose the respective application from the usr\bin folder. In this case, the link was usr\bin\software-center. This should solve the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.