After upgrading from 13.04 to 13.10 Dell's Inspirion 17R subwoofer stoped working.

In Ubuntu 13.04 was workaround by adding in the file /etc/modprobe.d/alsa-base.conf next line:

options snd-hda-intel model=ref

This issue was discussed here: How to activate subwoofer in Inspiron 17r?

After update previous workarounds don't help and I get no sound from any speaker in this case.

Is there some other fix for the latest version?


I have a Dell 17R as well and had to use hdajackretask to get the subwoofer to work again.

  1. Install hdajackretask by installing alsa-tools and alsa-tools-gui.
  2. Open hdajackretask.
  3. Select "Show unconnected pins".
  4. Find pin 0x10 and choose "Internal Speaker (LFE)".
  5. Click "Install Boot Override".
  6. Restart and you should be good to go.
  • This sort of worked, first after "Apply now" there is no change (in sound or sound options), after applying the "boot override" and restarting all the sound goes through the subwoofer (horrible). I also have a Dell 17R. – alfC Jan 8 '14 at 3:04
  • This basically worked at the end with a slight modification Internal Speaker (Back) askubuntu.com/questions/211201/… – alfC Aug 28 '14 at 1:04

In HDAjackretask , ALong with overriding 0x10 pin as 'Internal Speaker (LFE)'.

Also override all connected pins leaving their value as is , that is , the default, in order to enable sound in all speakers . Then select install boot override and restart.

If the sound is not auto muted while connecting Headphones , disable Loopback mixing in alsa-mixer either by opening alsamixer and disabling Loopback Mixing or amixer set 'Loopback Mixing' 'Disabled' in terminal.

Hope it helps. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.