6

I was reading an article that warns not to use cinnamon 2.0 on ubuntu 13.10 or it will break. Is this true? This is the article.

http://news.softpedia.com/news/Cinnamon-2-0-Corrupts-Unity-on-Ubuntu-13-10-390736.shtml

6

Update 7. december 2013: This happened just at the release of 13.10, but it is reported that this shouldn't cause issues any more.

Yes, this is true, it happened to me as well. I couldn't login to the Unity session after upgrading to 13.10 and had to uninstall Cinnamon to get it working. It seems like this is the solution for everyone having a similar problem.

My knowledge is limited and I can't tell you the exact reason why this is happening :) But your link already gives a possible reason for the problem - a common gnome package.

  • So if you removed unity, then you could cinnamon? – Michael Scott Oct 18 '13 at 21:53
  • I think so,it was the same problem under 13.04 – Papachan Oct 20 '13 at 12:50
  • 1
    Yes my Unity broke after installing Cinnamon 2.0. But I prefer Cinnamon over Unity, so that's okay for me. – Swarnendu Biswas Oct 21 '13 at 21:14
  • This is not true anymore... – Bruno Pereira Nov 29 '13 at 20:04
1

From what I can tell, Cinnamon 2.0 still uses some parts of Gnome 3 that are different from the ones that Unity expects so you can only have one or the other working until Cinnamon totally removes all Gnome references from it. I prefer Cinnamon over Unity by far so installed Xbuntu to be sure I don't start with rogue Gnome parts installed and put Cinnamon on it as my desktop to try it out. On a fresh install I just did, the files I think are in conflict are:

gnome-session-common 3.9.90
gnome-session 3.9.90
g-system-monitor 3.8.2
g-terminal-data 3.6.1
g-terminal 3.6.1
gnome-session-fallback 3.6.2

I am pretty sure Unity needs other versions to run. Hope that helps.

1

While Cinnamon team is working to fix the issue, here is the quick way to fix it. Open a terminal and use the following command:

sudo rm -f /usr/share/upstart/sessions/cinnamon-se*

This will remove the Cinnamon files from the upstart session. The trick is suggested by Michael Webster of Cinnamon dev team.

1

The problem only occures with Cinnamon 2.0 from an additional repository. I recommend to uninstall Cinnamon by simply using sudo apt-get remove .*cinnamon.* and sudo apt-get remove .*nemo.*

The repository probably was disabled automatically during Ubuntu upgrade, but it might be good to check this or remove it: http://ppa.launchpad.net/gwendal-lebihan-dev/cinnamon-stable/ubuntu

Now reinstall Cinnamon and Nemo simply trough the Ubuntu repositories. You can use apt-get, Synaptic or even the Software Center.

With Ubuntu 13.10 Cinnamon and Nemo are easy to choose for all Ubuntu users! :) Though instead of version 2.0 you will get 1.8.4 (as of today)

0

Actually the situation seems to be slightly better than "you have to remove Cinnamon", at least with its more recent releases. I had the same issue because of Nemo which I prefer over standard Ubuntu file manager. So I uninstalled Cinnamon completely (via Synaptic, but the method does not matter really), logged into Unity which was working, and then installed Cinnamon again.

After this procedure, Unity (currently 7.1.2 version) is working quite normally as far as I can tell alongside cinnamon-2.0.12 and nemo-2.0.6 (at this moment). The only glitch is that it is not able to display any desktop background, be it plain colour or a photo.

Not the answer you're looking for? Browse other questions tagged or ask your own question.