3

This may not be a Firefox / Ubuntu specific issue.

When I Copy / Paste a web link with _ and ( ) it is rendered as %20, %28, and %29.

Yet in the Firefox URL these % symbols do not appear.

The %20 is particularly weird because the _ itself does render in the URL:

https://www.capitalsecuritybank.com/en/PDF/CSB_%20Account_%20Application_%20Form_%20%28Personal%29.pdf

Can anyone explain why the URL is different when Copied / Pasted?

4

This is because of encoding to UTF-8 to make sure hyperlinks (and other contained data in the URL) work even though they contain symbols or country specific letters. You can read more about this on http://www.blooberry.com/indexdot/html/topics/urlencoding.htm if you are interested.

If you just want to get rid of it, there's an easy solution. Go to about:config and set the following line

network.standard-url.escape-utf8: false

This should fix your encoding of links.

  • 3
    The information provided about the about:config option is incorrect, it only applies to UTF-8 characters. Try opening example.com/foo%20meh%E1%88%B4 for example. You will see that the last character turns into while the space is still percent-encoded. This happens because that is the standard, valid URLs do not contain spaces (otherwise text would be ambiguous, did you mean http://example.com/page is awesome as URL? Or "http://example.com/page" is awesome? – Lekensteyn Oct 18 '13 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.