3

The brightness icon is shown but nothing happens. Even if I try to change the brightness in "System Settings" nothing happens. The thing is it didn't happen with Ubuntu 13.04, so I would like to know how to solve it or how to erase the upgrade to use the 13.04 version.

2

Got the workaround for this

Edit the file /etc/default/grub. Change the line:

GRUB_CMDLINE_LINUX=""

to

GRUB_CMDLINE_LINUX="quiet splash acpi_osi=Linux acpi_backlight=vendor"

and then save and then run:

sudo update-grub

Then restart the computer, then it should work.

This might allow you to reduce the brightness from 'Brightness & Lock' in system settings. But your function combination keys might not work. Though this is not a perfect solution, you can get the job done with this :-)

| improve this answer | |
  • thanks for this solution, but it doesn't work for me. As a matter of fact, the brightness settings disappear entirely from the system settings if I do this --- slider is gone. – Ingo Oct 21 '13 at 6:43
0

Sort of worked for me. The hotkeys sort of work sometimes, I have at least dimmed the display from where it was.

The settings slider don't work at all!

The catalyst control for brightness works.

| improve this answer | |
0

One thing to try would be to create the file /usr/share/X11/xorg.conf.d/20-intel.conf with the following content:

Section "Device"

    Identifier  "card0"
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"
    BusID       "PCI:0:2:0"

EndSection

...and log out and back in again to see if it works. Try it without any additional kernel parameters.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.