29

I attempted to upgrade from Ubuntu 13.04 to 13.10 today, and mid upgrade the system started flaking out, and eventually locked up entirely. I was forced to restart the computer, and am now unable to get the computer to boot up at all.

When I boot currently, it takes me to the GRUB menu, and I can choose to boot normally, or boot in an older version. I have tried several things, which I list below, but no matter what, when I try to finish booting into Ubuntu, I receive the following error:

Filesystem check or mount failed. A maintenance shell will now be
started. CONTROL-D will terminate this shell and continue booting
after re-trying filesystems. Any further errors will be ignored
root@ubuntu-computername:~#

I have fun fsck -f and everything appears correct, no errors are reported. and it passes all 5 checks.

If I run fdisk -l then I get the following information:

Disk /dev/sda: 320.1 GB, 320072933376 bytes 255 heads, 63
sectors/track, 38913 cylinders, total 625142448 sectors Units =
sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 4096
bytes / 4096 bytes Disk identifier: 0x00010824

Device Boot Start End Blocks Id System 
/dev/sda1 * 2048 608456703 304227328 83 Linux 
/dev/sda2   608458750 625141759 8341505 5 Extended Partition 2 does not start on physical sector boundary. 
/dev/sda5  608458752 625141759 8341504 82 Linux swap / Solaris

Disk /dev/sdb: 320.1 GB, 320072933376 bytes 255 heads, 63
sectors/track, 38913 cylinders, total 625142448 sectors Units =
sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512
bytes / 4096 bytes I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x0fb4b7e8

Device Boot Start End Blocks Id System
/dev/sdb1   8192 625139711 312565760 7 HPFS/NTFS/exFAT

I am considering just installing a new OS on the other disk, that currently has nothing on it, and then just attempting to scrape my data off the old disk (thankfully I didn't encrypt the files).

Really my question is this: Can I salvage this Ubuntu install, or should I give up and just reinstall?

7
  • Part of the problem is that you're not actually giving us any logs of the real problem with that machine. You're just showing us one of the symptoms. How about the output of the boot process for starters?
    – Magellan
    Oct 18, 2013 at 18:57
  • I'm not sure what you mean, I never get any output on boot other than what I posted in my first quotation.
    – SamHuckaby
    Oct 18, 2013 at 19:19
  • When troubleshooting Ubuntu, turning the splash screen off from the Grub prompt would be a good idea.
    – Magellan
    Oct 18, 2013 at 19:52
  • Sam, press {Esc} when the splash screen appears to disable it and then you will see all the crunchy bits Magellan wants in his second request. More detail on that at askubuntu.com/questions/33416/…
    – K7AAY
    Oct 18, 2013 at 20:18
  • 3
    I faced the same problem (after upgrading from 13.4 to 13.10 64bit). My /var/log/upstart/mountall.log told me that /etc/default/rcS was missing. Thus I remounted my root partition with write enabled ( mount -o remount,rw / ) and copied /etc/default/rcS.dpkg-new to /etc/default/rcS. Ubuntu 13.10 booted afterwards but is still corrupted. I will perform a clean reinstallation of 13.10, but maybe this hint helps anyone.
    – user204862
    Oct 19, 2013 at 20:02

1 Answer 1

43

I think I've sorted it thanks to a post I found here: Root filesystem check fails after power failure during installation.

Run from maintenance shell one line at a time:

mount -o remount,rw /
dpkg --configure -a
mount -o remount,ro /
sync
reboot

Worked for me but only got the first 2 lines and couldn't do the rest as drive was busy. Rebooted and it seems to be working now.

9
  • I also had to do mount /boot before that.
    – utapyngo
    Oct 22, 2013 at 20:33
  • 1
    These instructions worked perfectly for me. Thanks for your help! I will note that I wasn't able to return the mount to read-only (line 3) as it said that my / was busy, but it let me sync and reboot, and now Ubuntu is working again.
    – SamHuckaby
    Oct 24, 2013 at 14:34
  • You are my new hero. Like @SamHuckaby, I, too, could not run the third command (mount -o remount,ro /). I think the error was that the filesystem was busy? I continued with the next command, and the environment is happy. Nov 10, 2013 at 4:54
  • Just confirming don't crap yourself if mount -o remount,ro / results in a filesystem busy error, because that's what happened to me. Skip it, run sync and reboot and everything should work fine. Thankyou Patrick, thankyou, thankyou.
    – Starkers
    Jan 9, 2014 at 3:26
  • I'm experience the same exact problem, but running these commands didn't work. I get lots of errors with the dpkg command and when I try to reboot it gets stuck and after a while I get these: INFO task recovery-menu:639 blocked for more than 120 seconds "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" INFO task S30killprocs:928 blocked for more than 120 seconds "echo 0 > /proc/sys/kernel/hung_task_timeout_secs"
    – Carlo
    Feb 3, 2014 at 9:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.