7

In Ubuntu 13.04 I had my compose key set to pause (by going to Sytem Settings, then keyboard_layout, option, and changing the compose key setting). In 13.10 the keyboard settings have been totally rearranged: the compose key is now set by going to Keyboard in System Settings, hitting the Shortcuts tab, then the Typing menu.

However, there is no option to select pause. How can I set the compose key to whatever key I want? Thanks!

11

I had the same problem and lost a couple of hours trying to resolve it.

I found a solution, based on what can be found here:

https://help.ubuntu.com/community/ComposeKey.

This is what you need to do:

In the terminal type:

sudo gedit /etc/default/keyboard

After typing your administrator's password, the text editor will open. Find the line that reads:

XKBOPTIONS=""

Enter the desired key value between the quotation marks. In my case it was compose:lwin – to map the left Windows key as compose. In your case it should be: compose:paus. So the line should look like this

XKBOPTIONS="compose:paus"

A list of possible options can be found when you type

grep "compose:" /usr/share/X11/xkb/rules/base.lst

in the terminal. Log out, log in again – should work just fine.

(PS: Why they turned off the possibility to customize this easily in the system settings, still remains an unresolved problem.)

| improve this answer | |
  • 1
    No clue why the possibilty to customize was removed, but thank you very much! – Aibara Oct 30 '13 at 22:46
  • 3
    You don't need to edit your system files. Use dconf-editor to change org.gnome.desktop.input-sources, xkb-options. For example, mine reads: ['caps:swapescape', 'altwin:meta_alt', 'compose:prsc']. – P-Nuts Feb 9 '14 at 12:05
  • 1
    @P-Nuts thanks, nice hint. This is what bother me with the keyboard thing --- there are at least 4 different places where you can change this and I (and probably no one) knows exactly how they interact. If you have a link... post it there. – Rmano May 1 '14 at 15:21
  • That answer claims that this answer still works on ubuntu 18.04 but it does not work for me with compose:lwin-altgr – lucidbrot Mar 27 at 18:11
  • This answer works for me on ubuntu 18.04! – lucidbrot Mar 27 at 18:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.