4

Updated the Lubuntu from 13.04 to 13.10 on my MacBook Air. Ever since, when I open up the lid after standby, the system wakes from standby but after a few seconds it goes into standby again. There seems to be another (new) process putting my device into sleep mode now, too.

If I kill xfce4-power-manager, it only goes to standby once. However, it shouldn't go into sleep at all when xfce4-power-manager is not running.

How can I track down the new trigger of the standby mode?

2

EDIT: This is fixed in xfce4-power-manager 1.2.0-2ubuntu1.1. Install that version from saucy-updates to fix this issue without the workaround of editing /etc/systemd/logind.conf.


I have the exact same problem, see bug raised at https://bugs.launchpad.net/ubuntu/+source/xfce4-power-manager/+bug/1241896.

There's a similar bug with gnome-settings-daemon apparently (#1180513) and someone mentioned logind may be the culprit but currently it's not clear if that's the root cause, or if there's a workaround. Also 1180513 apparently had a fix released but users are still reporting problems.

In the meantime follow bugs 1241896 and 1222021 for a XFCE resolution.

  • 1
    Temporary workaround is to set: "HandleLidSwitch=ignore" in "/etc/systemd/logind.conf" – M4he Oct 20 '13 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.