This question already has an answer here:

After upgrading to Ubuntu 13.10 I have problems with Aptana and Titanium IDE. The menu bar doesn't work normally. Only one menu works, in Aptana the "Window" menu, in Titanium the "Run" menu. Other menus look empty.

Aptana:

enter image description here

Titanium:

enter image description here

Also HUD doesn't search in those menus.

What is the problem and how can I fix it?

marked as duplicate by kiri, jrg Jan 2 '14 at 14:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Here is what worked for me:

sudo -H gedit /usr/share/applications/eclipse.desktop

update it to:

[Desktop Entry]
Version=1.0
Name=Eclipse
Exec=env UBUNTU_MENUPROXY= eclipse
Terminal=false
Icon=/opt/eclipse/icon.xpm
Type=Application
Categories=IDE;Development
X-Ayatana-Desktop-Shortcuts=NewWindow
[NewWindow Shortcut Group]
Name=New Window
Exec=env UBUNTU_MENUPROXY= eclipse
TargetEnvironment=Unity

For me this worked for Aptana 3.4.2

sudo -H gedit ~/.local/share/applications/aptana3.desktop

Path depends on how you have installed Aptana. It could also be in /usr/share/applications/

[Desktop Entry]
Version=3.0
Name=Aptana Studio 3
Comment=My Favorite IDE
Exec=env UBUNTU_MENUPROXY= /home/xxx/Programs/Aptana_Studio_3/AptanaStudio3
Icon=/home/xxx/Programs/Aptana_Studio_3/icon_64x64.xpm
Terminal=false
Type=Application
Categories=Utility;Application;IDE;Development;

Important to note : Exec=env UBUNTU_MENUPROXY= /home/xxx/Programs/Aptana_Studio_3/AptanaStudio3

Change your Exec property and put the path to your Aptana launch file.

This will override your Unity menu and you will have a result like this:

enter image description here

Menus will be inside of your window, with all drop-downs working.

  • works for android ADT too, with little changes obviously. Thanks! – ademar111190 Nov 3 '13 at 4:56

protected by fossfreedom Oct 19 '13 at 18:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.