I was using a custom keyboard layout. Basically I modified the us-mac layout to fit my ideal of a math-heavy version of the regular us layout that also throws German umlauts into mix. It went well and worked marvelously for 6 consecutive versions of Ubuntu. Today's version Upgrade (from 13.04 to 13.10) broke that streak. I now have the usual crappy Macintosh-Layout.

Now xkb just ignores my layout and all of the other changes I make in /usr/share/X11/xkb/symbols/us (tried to switch '0' and '9' everywhere and rebooted - no effect). Why is that?

I suspect I have to do an extra step now for the changes to take effect or something like that. Anyone care to point me in the right direction?

  • Btw. Sorry I have to vent a bit, that's the first time I wine about upgrades, just can't help it: Its just I could rage on an on about Ubuntu upgrades. This time I thought 'its just software update, no new features or major nonsense'. But no, the upgrade broke my lightdm, which I repaired, some of my shortcuts got lost, my udev rules were all srewed and some more minor things. Why canonical? Why? I usually reinstall from scratch because the upgrades are so bad! – con-f-use Oct 18 '13 at 15:31
  • 1
    Erm, release upgrade (13.04->13.10) does by definition bring major changes and new features, that's the point of upgrading to a "different release" – ignis Oct 18 '13 at 17:48
  • Yes, I'm not complaining about the fact that something changed. I'm complaining about the fact, that basic functionality was broken. Stuff that is supposed to work and did in previous releases. Stuff that is essential and will probably work again after a few updates and hotfixes. Also compared to past version jumps (e.g. when they introduced unity or upstart) the one from 13.4 to .10 was very minor, mainly rounding the edges since mir is not included and chrome didn't become the standard browser just yet. – con-f-use Oct 18 '13 at 20:32

I had the same problem and found sudo dpkg-reconfigure xkb-data will make the changes take effect.

No logout needed if you have enabled multiple layouts; just change the layout once.

| improve this answer | |

I've just found a solution for this problem:

Delete the xkm files in /var/lib/xkb, log out and log in.

Some lines in /var/log/Xorg.0.log indicate that Xorg recompiles and reuses keyboard layouts now:

XKB: generating xkmfile /var/lib/xkb/server-FC37972E27A8F94CD9F5DD859C120B9D933CC5F8.xkm
# and on a next restart:
XKB: reuse xkmfile /var/lib/xkb/server-FC37972E27A8F94CD9F5DD859C120B9D933CC5F8.xkm
| improve this answer | |
  • No need to logout, switch to other layout then back. new xkm's will be generated and the new change will be active. thank you. – user.dz Mar 25 '14 at 21:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.