5

Since I upgraded to ubuntu 13.10, my flash isn't working anymore in firefox or opera. It only works in Google Chrome as it is included in the browser. I did check that I have flash plugin for firefox and so on installed. Everthing did work before the upgrade. When I try to install from adobe's website, it doens't pick up anymore the apt installer/ software center. You have to physically to go and look for the correct program to install flash, but I don't know where to look for it or choose it. Is there a other way like in terminal or somewhere else to reinstall it? Or what can I do?

  • 1
    Try sudo apt-get install flashplugin-installer – chronitis Oct 18 '13 at 12:38
  • I have tried that, but is already installed – Orosjopie Oct 18 '13 at 12:41
  • Maybe it is a matter of enabling the shockwave plugin within Firefox. – Dan Oct 18 '13 at 13:16
  • I just tried that and installed the plugin also for firefox, but still no change – Orosjopie Oct 18 '13 at 13:32
5

I had a similar issue after upgrading. I found the removing flashplugin-installer first then re-installing it (as suggested by chronitis) worked:

sudo apt-get remove flashplugin-installer
sudo apt-get install flashplugin-installer
| improve this answer | |
  • 2
    You're better of using purge instead of remove. – Joren Nov 6 '13 at 14:36
0

I don't know that is bug or may be older version like.

download the tar file from this location and install this tar file.

http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.310.orig.tar.gz

it is updated version of the flashplugin.

| improve this answer | |
  • Thanks, but the previous solution I got did work and it fixed my flash problem. – Orosjopie Nov 7 '13 at 5:56
0

I had to do a manuall install of libflashplayer.so to make it work.
This is how I did..

Go to http://get.adobe.com/flashplayer/
Download the tar.gz from the dropdown list.

mkdir -p ~/src/flashplayer
sudo mv ~/Download/install_flash_player_11_linux_x86_64.tar.gz ~/src/flashplayer/ (or whatever your download folder and architecture are)
cd ~/src/flashplayer/
tar zxvfp install_flash_player_11_linux_x86_64.tar.gz
mkdir -p ~/.mozilla/plugins
cp libflashplayer.so ~/.mozilla/plugins

Restart Firefox and see if it works..

I did a write-up here 1

| improve this answer | |
0

sudo apt-get install ubuntu-restricted-extras This command need to install flash player and more usefull extensions, like video-audio codecs.

| improve this answer | |
  • s/buntu/ubuntu/g – Peter Johnson Dec 12 '13 at 12:02
  • What this mean? – L.V.A Dec 12 '13 at 12:53
0

I just fixed the same problem under xubuntu 13.10 with only that line:

sudo aptitude -f reinstall flashplugin-installer

Strangely, dpkg-reconfigure flashplugin-installer did not do anything, seems like adobe-flashplugin_11.2.202.327.orig.tar.gz is not downloaded at the time of the installation

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.