Ubuntu 13.10 installed ok on my macbook pro 7.1.

By default it was using the opensource video driver which just about worked (I could log into unity), but froze after about 5 minutes of use each time.

After trying to install the various proprietary nvidia drivers I get a black screen after reboot:

  • refited screen: ok
  • grub menu: ok
  • ubuntu logo appears on screen: ok
  • black screen: not ok
  • Can you be more specific on how you tried to install the proprietary Nvidia driver, please? – David Foerster Oct 19 '13 at 2:09

I'm guessing you installed Ubuntu in EFI-boot mode? The nvidia drivers does not work in EFI-boot mode and if you want to use the nvidia driver you would have to change to legacy boot mode.

Since you got your display back, you can run this simple snippet to determine if you have installed in EFI-mode:

[ -d /sys/firmware/efi ] && echo "EFI boot on HDD" || echo "Legacy boot on HDD" 

And here is an guide on how to convert to legacy boot mode:


I had the same problem on my Macbook Air.

Here's a thread on the nvidia forum about adding support for efi-mode:


Here's a reference for nvidia chipset not working in efi-mode:



I was able to get the built-in gallium driver to work by sshing over to my system on which the display did not work.

Then I added nomodeset to /etc/default/grub on this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset splash"

And then afterwards you must run:

sudo update-grub

While I am no longer dead in the water, I am not able to get any version of Nvidia drivers to working at all on my MBP 9.1 which means my external displays do not work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.