30

I'm using multiple monitors.

When logged in everything is fine: The left monitor is positioned to the left and the right monitor is positioned to the right, but before I log in, the login-screen positions them the other way around.

This is also the position presented by bios and then the grub menu.

I don't mind where the login is displayed, but when moving the mouse, the boundary is the wrong way around and that's annoying.

55

I was experiencing this too. So long as you have your monitors configured as you want them in your user space then you should be able to follow these steps to set your monitors up the same way on the log in screen:

  • Open a terminal
  • Type sudo cp ~/.config/monitors.xml /var/lib/lightdm/.config/
  • Enter user password
  • Reboot your computer

Kudos goes to this post over here for pointing me in the right direction: Wrong Login Screen Resolution

  • Just wanted to say that this also worked for getting the monitor rotation set up correctly for the login screen. Thanks for the solution. +1 – reirab Mar 12 '14 at 19:06
  • 4
    Thanks for pointing me in right direction but the same thing can be done with just one command from users home folder: sudo cp .config/monitors.xml /var/lib/lightdm/.config/ – Tanel Mae Mar 14 '14 at 17:26
  • This truly helpful solution!!! – Dmitry May 19 '15 at 7:33
  • 1
    I got a permissions error after copying and rebooting, so I needed to sprinkle in some "sudo chown lightdm:lightdm /var/lib/lightdm/.config/monistors.xml". Otherwise, excellent! – Nick Nov 12 '15 at 20:32
  • 1
    Along the same lines, I created a link with "sudo ln ~/.config/monitors.xml /var/lib/lightdm/.config/". It does the same thing but has the advantage of being alterable at a future date, without having to re-copy the config file each time the display layout is changed via the "Displays" GUI. – Rich.T. Apr 12 '16 at 16:41
1

At least with Ubuntu 16.04, which includes lightdm-gtk-greeeter 2.0.1, the following entry in /etc/lightdm/lightdm-gtk-greeter.conf can be used to fix the initial position of the login dialog on a certain monitor. This setting isn't available via the settings UI.

[greeter]
active-monitor=0

The monitors.xml workaround didn't work here, too.

  • Doesn't work with lightdm unity greeter, which is what I'm willing to use. – Anwar Apr 1 '17 at 13:34

protected by Sylvain Pineau May 1 '15 at 13:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.