13

IBUS icon does not appear after upgrading to Ubuntu 13.10. I can't even find the IBUS icon from the Dash. May I know how to reactivate the IBUS? Thanks.

2
  • What about reinstalling ibus? Did you try to install it again?
    – Anwar
    Oct 18 '13 at 5:29
  • Have you checked system settings -> Text Entry?
    – clueless
    Oct 18 '13 at 20:13
12

Several of the settings from ibus-setup have been moved to System Settings >> Text Entry, but something in this change to the backend has broken some key functionality in Ibus. Ultimately, this needs a bug report; but I haven't figured out exactly what to report just yet.

Depending on the languages you use Ibus for, you may still be able to get it to work well enough.

State of Ibus after installation

After a fresh install of 13.10, I could not add Ibus input sources in Text Entry. Moreover, although apt showed Ibus as installed (which it was), searching in the Dash showed Ibus as not installed.

Partial resolution

Reinstall Ibus: sudo apt-get install --reinstall ibus

After reinstalling Ibus and rebooting, Ibus input methods were available in Text Entry.

Some methods, such as Anthy for Japanese, seemed to integrate well with the new system. Anthy configuration settings were available from a button that appears next to the keyboard layout button when Anthy is highlighted in Text Entry. All in all, Anthy worked fine.

So depending on the language you need, you may find everything is ok after reinstalling Ibus.

Larger problems with Chinese input methods

Chinese input methods from Ibus seem to be completely broken. ibus-setup can no longer communicate properly with DConf, reporting permission problems accessing /run/user/<uid>/dconf/. The settings themselves are still available in dconf-editor, but most of them do not seem to be honored by the new backend setup and changing them had no effect. When highlighting the Chinese input methods in Text Entry, a configuration button did not appear like it did for Anthy.

As a result, it no longer seems possible to change the pinyin configuration or show the configuration menu. In it's current initial state, pinyin input offers both simplified and traditional characters for some words, but not all of them, making it impossible to type in one or the other, let alone to switch on the fly. Changing the simplified/traditional setting in dconf-editor is one of the few that worked -- but only after rebooting, which is obviously not practical.

Suggestion

I imagine these issues will be fixed in time as the bug reports start coming in, but one suggestion is to use fcitx if you need Chinese input. fcitx is used by Ubuntu Kylin. Install it, switch the default input method in System Settings >> Language Support to fcitx, and reboot. After that, configuration menus for all input methods were available again. (You don't need to uninstall Ibus if you will still use it in some cases.) Like Ibus, several fcitx input methods have separate packages, so you may want to browse the packages in Synaptic.

3
  • Thank you so much for your explanation. In fact, I'm using Chinese input. In this case, I have to wait for the next update and hopefully this will be fixed. Speaking of fcitx, can I type Traditional Chinese character in pinyin (IBus allows user to do so)?
    – PeterW
    Oct 20 '13 at 11:48
  • @peterw. I'm glad it worked out. If this has answered your question, please check it as the accepted answer. :) Yes, once you have switched to fcitx, you will be able to switch between traditional and simplified on the fly while using pinyin input. I recommend using fcitx. I suspect that ibus pinyin will take a while to be fixed. The config menus in fcitx are very different from ibus, but not hard to figure out.
    – chaskes
    Oct 20 '13 at 18:12
  • I'd like to point out that one potential point of failure is the remapping of the default Input Method switch keyboard shortcut to Super-Space. I found that, after changing this shortcut to Ctrl-Space in 13.04, it was hanged to the default Super-Space in 13.10. Since I'm on a small, old laptop, the Super key has been relocated above Backspace, making it less than useful for this sort of thing, which is why I remapped it in the first place. So, make sure your shortcuts are mapped properly after update to 13.10.
    – Dakota
    Mar 4 '14 at 22:58
2

I found the answer to fixing this to work with Korean by the following, which basically says you to into terminal, then type

ibus restart

ibus-setup

Then you can adjust the settings for the ibus that are missing in the menus! It worked for me, and now I am able to use Shift+Hangul key after setting it the way that I want. So I suggest you type those two lines into terminal.

:

한글키로 한영전환은 잘되고있습니다....


우선 제가 사용한 방법은...

그냥 소프트웨어 센터에서 ibus-hangul 만 체크해서 설치하고

언어설정에서 기본입력기를 ibus로 바꿔주고

터미널에서

ibus restart

ibus-setup
1
  • I have edited the post. Please verify if I have missed something or did something that should be fixed. Thanks
    – Lucio
    Jan 27 '14 at 3:55
2

I found no way to get the ibus icon, either on the desktop nor on the upper bar. But just typing ibus-setup in a terminal gave me access to the settings of ibus.

  • Then I can access and select the ibus keyboard layout with the shortcut applied.
  • An icon does appear on pressing the shortcut.
  • Using LibreOffice, I had to choose another shortcut than the default [Super-Space], adding a [CRTL-ALT-Space], which does work correctly.
  • Also, as I have a Swiss-French keyboard, I must select "Use the system keyboard" in the advanced setup, otherwise I get a US keyboard layout.
2

Open a terminal window and type/paste:

dpkg -l ibus* | grep ^ii| awk '{print $2}' | xargs sudo apt-get --reinstall install

Then reboot. After rebooting click on 'Text Entry Settings', followed by + / add-option and choose your language.

Then it should work just fine.

0

I also found that there is something wrong with ibus. And now I just can't input any chinese to my emacs, which works prefectly on ubuntu 13.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.