I made the mistake of installing the Nvidia Linux drivers direct from their website. It failed because it could not remove the nouveau driver.

Next I manually installed the nvidia drivers from the repository which successfully installed the nvidia driver, but the Ubuntu desktop does not function; no launcher, no menu bar, no windows. (Gnome seems to work though).

So I want to revert back to the vanilla installed nouveau driver. I tried

sudo stop lightdm
sudo apt-get purge nvidia*
sudo apt-get install xserver-xorg-video-nouveau
sudo rm /etc/X11/xorg.conf
sudo reboot

but lshw -c video reveals I still have one nvidia driver and one i915 driver. nouveau has not returned and the desktop will not function.

I am considering a complete reinstall, is there anything else to try?

I have followed the other threads with the same issues, but the solutions did not work

sudo dpkg-reconfigure xserver-xorg

Creates an error.

sudo apt-get install --reinstall xserver-xorg.core libgl1-mesa-glx

Did not make a difference.



  • For me, substituting in a xorg.conf file worked, even using the failsafe one already in the folder. If there's absolutely no xorg.conf, it'll likely not work.
    – xji
    Dec 6, 2015 at 10:27

5 Answers 5


Had the same problem.

sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx

This actually fixed it. Ubuntu 13.10 x64 + nVidia 740M. Thank you very much!

You did not mention your GPU. If you've had that problem on a laptop, I'd suggest its because of the so-called "Fusion" system (which uses your integrated GPU in lieu of discrete one when you don't need it).

  • This should be xserver-xorg-core I guess.
    – MadMike
    Dec 18, 2013 at 6:38
  • Do not recommend to run it on 16.04. Just killed all xserver for me Jan 9, 2019 at 3:30

Ultimate fix:

sudo stop lightdm
sudo apt-get purge nvidia*
sudo apt-get install xserver-xorg-video-nouveau
sudo apt-get purge bumblebee
sudo reboot now

Do not remove xorg.conf file, I repeat do not remove xorg.conf.

  • 1
    Why not to remove xorg.conf ? If there is some nvidia-specific stuff inside, I quess it could bring X to dont work any more. I just moved it to xorg.conf.backup and did the reboot --> worked like a charm, so I deleted it.
    – Alex
    May 27, 2016 at 9:54

Be sure you remove all blacklist entries involving nouveau from /etc/modprobe.d as well.

Otherwise even if the system is configured to use it, it will not. I believe blacklist-local, and the nvidia backlists will be of primary concern.


I had the same issue. Mine turned out to be a badly configured bumblebee.conf referencing nvidia-304 in one place and nvidia-current in another.


Try this:

cd /etc/modules-load.d/ 
mv nvidia.conf nvidia.conf.backup

cd /etc/modprobe.d/
mv nvidia-blacklists-nouveau.conf nvidia-blacklists-nouveau.conf.backup
mv nvidia.conf nvidia.conf.backup
mv nvidia-kernel-common.conf nvidia-kernel-common.conf.backup

Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.