1

Netflix Desktop was working fine until I upgraded to Ubuntu 13.10 today. Now, it gives me the message that the silverlight plugin has crashed. I tried different workarounds and to even downgrade my silverlight version to 4--apparently 5 does not work.

I would appreciate help with this issue, and I'm sure I'm not the only one experiencing it.

1
  • I tried Pipelight as well without success. – ubuntUser Oct 19 '13 at 4:26
2

you need to uninstall netflix-desktop and wine-compholio by purging them both

apt-get purge netflix-desktop wine-compholio

After this is done follow the instructions here:

http://www.webupd8.org/2013/08/pipelight-use-silverlight-in-your-linux.html

0
0

Thanks! Actually, I was able to solve it a few days ago using the last few comments here. It was determined that my issue had something to do with hw-acceleration. I didn't get the chance to post back here.

0

If you tried pipelight without success do this:

sudo pipelight-plugin --disable-all

sudo rm /usr/lib/mozilla/plugins/libpipelight.so

pipelight-plugin --disable-all

In my case the problem was related to hardware acceleration. Running netflix desktop using the command below worked for me:

wine-browser --disable-hw-acceleration

If the above works for you you can make changes to the launcher that will stick until the next update to netflix-desktop by issuing the following commands:

sudo mv /usr/share/wine-browser-installer/hw-accel-default /usr/share/wine-browser-installer/hw-accel-default2

echo -e '#!/bin/sh\nexit 1;' | sudo tee /usr/share/wine-browser-installer/hw-accel-default

sudo chmod +x /usr/share/wine-browser-installer/hw-accel-default

Source: https://answers.launchpad.net/netflix-desktop/+question/237615

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.