12

I have this weird issue on my laptop right now. The keyboard is not functioning 100%. This means, I can type my login details to get into Ubuntu. I can type something on Dash. But other than this (on the desktop), no output from the keyboard when using all the other apps - as in I start to type and nothing comes out.

The surprising thing is that when I shift to Guest session, the keyboard functions normally.

When I shift to another TTY, like Alt+F5, keyboard works normally.

This is the first time I've encountered this so far in my use of Linux. Keyboards normally never fail on any of the desktop environments I've used over the years.

Any ideas what's happening? Could be the config files on my home is too messy already. I've upgraded this from 11.10 to 13.04, then now 13.10 without a re-install. Works fine so far, until now that I can't do much without a keyboard.

Thanks in advance!

P.S. Mouse and touchpad works fine.

19

This solution might work as suggested by Andrew @ http://www.webupd8.org/2013/10/ubuntu-1310-available-for-download.html

GO TO:

1) System Settings > Language Support, or you can hit Super (Windows key) to open the Dash, then type Language Support

2) At the bottom part find "Keyboard input method system"

3) Switch between "Default", "IBus" and "None". It may be different in your case, so try each one out. Start with option None.

4) After making the change, you need to restart for the settings to take effect.

Below is a screenshot.

enter image description here

| improve this answer | |
  • Strangely, this still does not work for me :( tried setting all options. – vissi Nov 22 '13 at 8:31
  • Could I remove some settings manually to reset it? I tried moving .gconf and .xinputrc, but no result. However, keyboard works fine on newly created user account. What's the difference? – vissi Nov 22 '13 at 8:33
  • Have you found a fix already? I have not tried too look deeper into the cause of this issue, and thus have not found any other fix aside from the above. Make a backup of those config files you want to modify/remove before proceeding so you can easily revert. – Marky Dec 17 '13 at 17:38
  • 1
    For me too, selecting None worked. – shahensha Feb 21 '14 at 0:07
  • Deleting .xinputrc worked for me, thanks @vissi! – Amedee Van Gasse Jan 16 '18 at 17:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.