I installed ubuntu 13.04 on a 16GB usb memory (full installation, not live usb) and boot it with vmware player 6 + plop under windows 7 64-bit host.

To avoid windows format complain, I created a FAT32 partition at the beginning of the USB memory, with a second partition being ext and followed by a swap partition.

The problem is, when I boot from the USB, it shows an error: Attempt to read or write outside of disk hd0. But it then allows me to boot in to ubuntu. once boot, everything seems to work as it should. But the error message before the boot bothers me a lot.

I run fdisk command and got the following results:

Device     Boot      Start         End      Blocks   Id  System

/dev/sda1   *        2048     3999743     1998848    b  W95 FAT32
/dev/sda2         4001790    30799871    13399041    5  Extended
/dev/sda5         4001792    28801023    12399616   83  Linux
/dev/sda6        28803072    30799871      998400   82  Linux swap / Solaris

It seems that the system recognizes the FAT32 partition as boot. I also tried to use boot-repair but the problem remains.

Would you mind giving me some advice on how to get rid of that error message at boot? I can boot into ubuntu so this is not a big issue but I do not really want to see that error every time I boot from the USB. Plus it seems to take a long time before the message is displayed, I think there might be a time out sort of thing for this error, which, as a result, slow my boot up time.

Thank you in advance for your help. Lei


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.