I have the RT3290 Ralink wireless card run using the original RT2800 driver that came with the 13.04 system, on an ASUS F75V laptop. Every time I reboot, Rf-kill shows the wireless as hard-blocked. It cannot be unblocked using neither Rf-kill nor the supposed Fn+f2 key combination, as various other posts suggest. After boot, in network manager, both the wifi and the airplane mode show up as "off". I dug up a workaround on some obscure forum thread which I unfortunately was unable to dig up again (this was awhile back):

  1. Turn airplane mode on (it stays on).
  2. Hit the "on" button for the wireless (it will go back to off very quickly).
  3. Immediately send the computer into sleep mode.
  4. Wake the machine up. Wireless is working (it's a miracle!).

Unfortunately, the effects don't last past the next system boot. I am tired and annoyed by having to redo this "trick" over and over again...

So, I tried the official RT3290 driver (Following this post: How do I get a Ralink RT3290 wireless card working?).

After reboot, the wireless was supposedly on (not blocked as usual). However, no wireless networks were discovered (and this is at the same location where the RT2800 driver worked previously without fail after the "trick").

I removed the RT2800 driver from the blacklist, and now I'm back to the airplane-sleep trick workaround.

Any suggestions on how to fix it once and for all?


UPDATE: I upgraded to kernel 3.11.5 and tried the rt3290sta driver again. Unfortunately, same result... Wireless is on and unblocked, no networks visible. Just to confirm that I have RT3290,

lspci -nnk | grep RT

yields 03:00.0 Network controller [0280]: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe [1814:3290] 03:00.1 Bluetooth [0d11]: Ralink corp. RT3290 Bluetooth [1814:3298]

Out of curiosity, I tried the ole' airplane-mode trick. After emerging from suspend, the wireless worked! What this shows is that either rt3290sta and rt2800pci suffer from the same problem, or, more likely, that the problem is not in the driver itself but elsewhere.

  • OP answer - solved by this post ^ – Zanna Oct 25 '16 at 9:20

What finally solved the problem was this solution by @chili555 here: Wireless disabled by hardware switch on an Asus X550V

For me, values 1 and 4 both worked. As an aside, at the moment of this post I am on Trusty alpha (yikes!), which means the 3.12 kernel, and using the rt2800pci driver that came with the kernel by default.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.