Ubuntu has upgraded to 13.10, but when I reboot I can't login, even when I try with the guest session. I am brought back to the login screen.

I press Ctrl+Alt+F1 and login. Then I remove the file ~/.Xautohrity and reboot. After that it can login from LightDM but a new error appears:

Could not acquire name on session bus

and when I reboot it can't login again.

How can I fix this? Note that I have another Desktop environment installed alongside Unity.

  • What do you mean "can't login"? Is your password rejected? Do you see an error message? Or are you brought back to the login screen right after? In the latter case: I've seen at least five questions about that today so please use the search for that. Please edit your question to include those details. – gertvdijk Oct 17 '13 at 22:30
  • I'm being brought back to the login screen right after. I will look up for similar posts. – joshjo Oct 17 '13 at 22:53
  • Again: please edit your question to include that - it's how this site works; it's not a discussion forum, you see? – gertvdijk Oct 17 '13 at 23:06
  • Relevant (or even duplicate, but not able to mark as such - no upvoted answers). How do I prevent being kicked back to the login screen every time? – gertvdijk Oct 17 '13 at 23:08

I had a similar problem but fixed it by removing Cinnamon. If this is also the case for you, try the following: sudo apt-get remove --purge cinnamon* and then sudo apt-get autoremove

If you don't have cinnamon installed but any other desktop environment alongside Unity, try to uninstall those. (Gnome fallback should be fine though)

  • Ok, that helps me :D – joshjo Oct 18 '13 at 20:35

I solved by opening the terminal (Alt+Ctrl+T) and enter:

sudo /usr/lib/lightdm/lightdm-set-defaults --show-manual-login true

Restart the computer


I had the same problem. I wasn't able to login to my user account then I logged in as guest and in terminal switched to my user account as I didn't know what is the password for guest account then typed this command and restart:

sudo /usr/lib/lightdm/lightdm-set-defaults --show-manual-login true

It will give you three options when you want to login again after a restart:

  1. Your user account
  2. Manual login by typing the user name and password
  3. Guest

The 'manual login' option worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.