I was wondering if Jupiter (Interface for display, power and device control) will work in Ubuntu 13.10, because my laptop (Toshiba Satellite C855D, AMD A6-4400M with Radeon HD Graphics running Ubuntu 13.04 x64) keeps overheating, I tried some other tools, like laptop-mode-tools or TLP, none of those work, not at all. Jupiter was the only option and it's supposedly discontinued, the version I'm using is being maintained by JoliCloud team, but they told me they're not sure if it will work with 13.10... If it doesn't work, I'm definitely not upgrading, since overheating is a major issue for me... Thanks in advance!


do not use jupiter. It does not work properly on 13.10. By the way I have gained approx. 1 hour more battery time by using this :

sudo apt-get install laptop-mode-tools

Use TLP instead

sudo add-apt-repository ppa:linrunner/tlp

sudo apt-get update

sudo apt-get install tlp tlp-rdw

sudo tlp start

My system Lenovo G780 i7 / 8GB / dual hdd

  • You cannot use laptop-mode-tools and TLP at the same time: Error: TLP power save is disabled because laptop-mode-tools is installed. Please uninstall laptop-mode-tools. – don.joey Nov 4 '13 at 8:51
  • I've already tried TLP and laptop-mode-tools, none of those work as I expect, my laptop keeps overheating when using one of those tools (as @don.joey says, they can't be used at the same time) – Daniel Pacheco Nov 17 '13 at 16:50

What you want to do is add the repository from jolicloud. Here are the steps to install it on Ubuntu 13.10:

  1. In the terminal enter:

    sudo add-apt-repository ppa:jolicloud-team/ppa
  2. Go to Software&Updates in Ubuntu

  3. Then select Other Software tab
  4. Then you want to click on http://ppa.launchpad.net/jolicloud-team/ppa/ubuntu
  5. Then click Edit
  6. Then in the Distribution box change saucy to raring. Then click okay and close Software&Updates.
  7. Now in the terminal enter:

    sudo apt-get update
  8. Lastly in terminal enter:

    sudo apt-get install jupiter

Now you have installed Jupiter!

  • That's how I installed it in 13.04, but it doesn't work in 13.10... – Daniel Pacheco Nov 17 '13 at 16:54

Check to see if you can disable your Catalsyt card via AMD drivers in case you have installed them, usually it needs a sudo, also you will need to reboot. The system with then run on Intel graphics and with TLP, it will bring temps down.


I recently ran across a possible solution in the article:


There is a program that they suggest as a replacement to Jupiter called TLP that is a power management applet for laptops and netbooks that prevents common overheating problems that might help, it's still being maintained unlike Jupiter so you'd be more likely to have success in the long run.

sudo add-apt-repository ppa:linrunner/tlp sudo apt-get update

no need for anything else just add the repository and it should do the rest

  • TLP and laptop-mode-tools don't work... – Daniel Pacheco Nov 17 '13 at 16:55

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.