5

I have a Samsung Notebook NP900X4C with an LUKS encrypted installation on it. The system is booting in UEFI mode.

The problem is that the samsung-notebook kernel module is disabled in UEFI mode and due to that I am missing features like the keyboard backlight.

Is it possible to modify the current installation so it can boot in BIOS mode?

Is this correct that the basic steps would be converting the disk from GPT to MBR and installing grub from a live CD? Would this be possible with a LUKS partition?

  • @karel: are you trying to re-open this? (pressed skip in the queue for now...) – Fabby Dec 15 '18 at 14:50
  • 2
    @Fabby Reopening this question seems like a good idea. There's so many unanswered questions about the Ubuntu installation USB won't boot at all, not even to a black screen, and instead the computer boots straight into Windows when trying to install Ubuntu. But Legacy boot will sometimes boot even if UEFI boot doesn't, and after installing Ubuntu grub must be converted from BIOS mode to UEFI mode. And sometimes it's also necessary to convert from UEFI mode to BIOS mode. – karel Dec 15 '18 at 15:25
  • 1
    Re-open vote cast, Your comment upvoted so the next one in the queue sees it as well. – Fabby Dec 15 '18 at 15:30
  • I reoepend it. I have no idea why it was closed. If you look at the answers you are clearly using ubuntu to modify the install.. Clearly on-topic – Seth Dec 15 '18 at 18:38
6

It's possible and it's easier than you think. Linux can boot fine from a GPT disk in BIOS mode, so there's no need to do the MBR-to-GPT conversion. With any luck, all you'll need to do is to install a BIOS-mode boot loader (GRUB, LILO, or SYSLINUX) to the disk. There are three caveats, though:

  • I've never used LUKS, so I'm not sure how this would affect things. I wouldn't expect any problems, but that might be my lack of experience talking.
  • Some EFIs have quirky requirements for booting in BIOS mode. Most commonly, some will only boot in BIOS mode if they see a boot/active flag on an MBR partition, and this is normally absent on GPT disks. You can work around this by using an old version of fdisk (one that lacks GPT support, which was added only very recently) to set the boot/active flag or by using a new version of parted to set a flag (whose name I don't recall offhand) on the whole disk. If you're lucky you won't need to deal with this issue. See this page for more on this problem.
  • If the computer is dual-booting with Windows, converting it to boot in BIOS mode is likely to be much trickier. In this case, it might be easier to install rEFInd as a boot manager. rEFInd can then boot Windows in EFI mode and boot the BIOS-mode GRUB (or whatever you end up using). To do so, though, you'll need to edit refind.conf: Uncomment the scanfor line and ensure that hdbios is among the items that are scanned.
4

I figured out the exact way by myself. Rod Smith was right, it’s easier than I thought.

Here the solution if anybody else needs it:

Original Partition Layout:

  • /dev/sda1 (EFI Partition)
  • /dev/sda2 (Boot Partition)
  • /dev/sda3 (LVM2/LUKS encrypted Root & Swap)

Converting to BIOS boot:

  1. I deleted the EFI Partition and created a new partition with the bios_grub flag instead of it.
  2. Using this tutorial I mounted the encrypted file system, chrooted into it and installed GRUB.
  3. Remove the EFI Partition from /etc/fstab.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.