I just upgraded to Ubuntu 13.10, but since the upgrade I don't have internet access via wifi anymore.

I can:

  • See networks
  • Connect to a network
  • Ping myself (localhost,

I can't:

  • Ping others (including other devices on the same wireless network, including the gateway/router)
  • Resolve hosts
  • Access any other external resource, whether on my own network or on the internet

Using Wireshark, I noticed my computer is continuously sending ARP-requests like "Who has [which is the gateway]? Tell". It doesn't get any replies though. When I ping another IP-address for which it knows the mac-address (from cache), it turns out a packet loss of >90% occurs, and even if a packet manages to arrive it takes around 3000ms.

The output of route -n is:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface         UG    0      0        0 eth1   U     9      0        0 eth1   U     0      0        0 virbr0

Before upgrading, wifi worked fine. Using other devices, wifi still works fine.Resetting the router didn't help. Ethernet still works after upgrading.

Any suggestions?

Update: I'm using the wl driver. Here's the relevant output of some commands:

lspci | grep Wireless
03:00.0 Network controller: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter (rev 01)

cat /etc/modprobe.d/blacklist.conf
blacklist mac80211
blacklist brcm80211
blacklist cfg80211
blacklist lib80211_crypt_tkip
blacklist lib80211
blacklist b43

cat /etc/rc.local
sudo modprobe -r lib80211
sudo insmod /lib/modules/3.2.0-30-generic-pae/kernel/net/wireless/lib80211.ko
sudo insmod /lib/modules/3.2.0-30-generic-pae/kernel/net/wireless/lib80211_crypt_wep.ko
sudo insmod /lib/modules/3.2.0-30-generic-pae/kernel/net/wireless/lib80211_crypt_tkip.ko
sudo insmod /lib/modules/3.2.0-30-generic-pae/kernel/net/wireless/lib80211_crypt_ccmp.ko
sudo modprobe wl
exit 0

The last lines are probably how I got wireless working after the previous upgrade (wireless has been a problem after each upgrade).

Update 2: added information about the exact hardware below.

The hardware is an integrated device, so I ran lspci -nn | grep -i network. The output is:

03:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)
  • Why are you trying to do a hard insmod of a specific kernel module version? That is likely to break stuff. Undo all of the edits you did for the previous Ubuntu versions and see if it works out of the box. Also please include the exact hardware details about your wireless card. See the section "Identifying the exact hardware" in my Q&A here on how to do that: askubuntu.com/a/235280/88802
    – gertvdijk
    Oct 17, 2013 at 21:08
  • Thanks for you reply, I was indeed trying to load a specific kernel module version. I removed all edits for the previous Ubuntu versions, and rebooted. It still doesn't work however (same symptoms as described before). I will update the question to include the details in the section "Identifying the exact hardware".
    – Simon
    Oct 17, 2013 at 21:23
  • I see you already posted some details, but with the numeric product/vendor ID we can find the exact match/solution probably. :)
    – gertvdijk
    Oct 17, 2013 at 21:25
  • Ah, so it's the 14e4:4727 This should be your answer (after you undone all the changes compared to a clean install): askubuntu.com/a/214196/88802 if you already did this, then sorry, but that is not included in your question.
    – gertvdijk
    Oct 17, 2013 at 21:47
  • Please also try askubuntu.com/a/359873/88802
    – gertvdijk
    Oct 17, 2013 at 23:15

6 Answers 6


Please do:

sudo modprobe -rv wl
sudo apt-get remove --purge bcmwl-kernel-source
sudo modprobe -v brcmsmac

now your wireless should be working.

  • Thanks, this did the trick. It stopped working after a reboot, though that was easily fixed by adding the line "modprobe brcmsmac # askubuntu.com/a/360632/203753" to my rc.local.
    – Simon
    Oct 18, 2013 at 7:18
  • Worked, although I observed a certain decrease of the signal strength
    – ezdazuzena
    Feb 10, 2014 at 22:07

If anyone else is experiencing a similar problem, and the guide above did not help, try using an earlier Linux kernel like 3.8. That was the only way I got around to this problem.

  • I had to go down to 3.8.0-17, 3.8.0-33 did not work.
    – RyanCheu
    Nov 25, 2013 at 22:13
  • I think 3.8.0-28 is the one I have. I have tried every new kernel version since, and I've come across this problem every single time.
    – Roberto
    Nov 26, 2013 at 17:39
  • @Roberto I'm having the same problem, but I don't have the option to boot 3.8.0-28. Can I download it from somewhere or is there something else I can do to add it to /boot? Dec 2, 2013 at 14:29

I unchecked the Using Broadcom 802.11 Linus STA wireless driver source in Software & Updates, Additional Drivers, rebooted, and everything works fine now.

  • That works too.
    – Tobu
    Dec 7, 2013 at 23:52

I also faced with same problem and i spent a lot of time googling for solution but nothing came for much help. atlast i found the solution and it was a very simple step. click wifi icon then select "edit connections" Then delete the wifi connections that are already stored in the list now connect freshly to ur wifi connection and reboot Now ur wifi will be working normally Enjoy :)

  • After upgrading to 13.10 I was having a similar problem with my wired connection. I also deleted the pre-existing ethernet connection and built a new one using defaults. This solved the problem for me. So +1 for @babugowd.
    – GSP
    Jan 22, 2014 at 1:59
  • Not sure why you were down-voted, this worked for me as well. Thank you very much. +1 Jan 25, 2014 at 4:44

I was having a lot of problems getting my wifi to connect, kept prompting me to enter my wifi password. I noticed when I was doing the installation it would connect to the wifi no problem then as soon as I pressed next it disconnected. So I thought if I skipped that part, whatever was causing it not to work wouldn't happen and, it proved successful. Install ubuntu... don't connect to wifi until the installation is complete. Hope that helps someone.


First run the following command in terminal

lspci -nn

Find out which driver corresponds to your WiFi. Usually this is of Broadcom Corporation.

Go to Dash, open "Software & Updates".

There you will see five tabs, out of which the last tab is Additional Drivers. In that tab, select the driver for the wireless. I had the same problem, and in my computer, the option "Don't use this device" was selected. I selected the other option, which was the driver for WiFi. Well, once you get there, you yourself will know what to do.

Please improve the answer, if you know anything that can be added here for further clarity.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .