4

Just upgraded to Ubuntu 13.10 only to find that Unity won't load (login freezes, after doing ctrl+alt+F1, logging in and then doing startx, I get a blank desktop and the mouse pointer, and nothing else). I can right click, but the only operations that work are "create new file" and "create new folder". For example, "change desktop background" doesn't work. Also, after doing a few right clicks and choosing "change desktop background", I get a warning message box: "compiz closed unexpectedly."

Guest login works fine.

Tried creating a new user, but I experience the same thing with the new user.

Tried removing all configuration files from my home directory... same thing.

Doing dconf reset -f /org/compiz/ gives an error "error spawning command line..."

Doing unity --reset also gives errors.

Tried uninstalling unity (and compiz) and reinstalling, but that doesn't help. Tried reconfiguring lightdm, didn't help.

I don't have any proprietary drivers installed.

Once again, the funny thing is that the guest session works fine.

  • 1
    See the second answer in How do I reset my Unity configuration? – user68186 Oct 17 '13 at 19:54
  • @user68186: Well, this would only try to reset things through dconf (it seems the command is only a wrapper for a bunch of dconf reset commands). But as I said in my post, dconf is misbehaving. When I run what you suggested, I get a whole host of errors: "failed to commit changes to dconf: error spawning command line..." – user69659 Oct 17 '13 at 19:59
  • Seems to be a problem with Cinnamon see: askubuntu.com/questions/360772/… – virtualxtc Oct 31 '13 at 5:13
  • Assuming you have Cinnamon installed. I don't. – user69659 Oct 31 '13 at 22:19
3

I had the same thing, and i press CRTL-Alt-T, to have a terminal. after that i enter ccsm to have compiz configurator. To the left, under all categories, i selected Preferences,and on the new screen i selected unity profil. Wait a few seconds and normally the launcher appers.

|improve this answer|||||
  • Thank you for your answer. I'll leave the question open for now, as I can't confirm this since I just went ahead and did a fresh install. – user69659 Oct 25 '13 at 2:58
  • Fixed this issue for me on Ubuntu 13.10. I started ccsm, clicked reset to defaults in the Preferences tab and experienced no more crashes ever since. – Nicolai Fröhlich Feb 7 '14 at 14:53
2

I can confirm that using ccsm solved my issue. I had some keybinding conflicts after the upgrade from 13.04-13.10 and as a result the "Enable Ubuntu Unity Plugin" box was unchecked.

|improve this answer|||||
  • Thanks! Maybe a comment below Marc-Andre's answer would be more appropriate. – user69659 Nov 11 '13 at 16:49
  • Hi, that solved my problem with unity (i could login but no unity functionality was available). – che--- Nov 24 '13 at 13:31
0

I had something similar. During install my mouse and keyboard didn't respond anymore so I had to reboot the hard way halfway during installation. After booting I could log in but only got a mouse pointer on a black screen. My solution: Ctrl+Alt+F2, login, sudo dpkg --configure -a I first tried sudo apt-get dist-upgrade but the prompt said I needed to give that command. It then configured lots and lots of software. I rebooted the system and all seemed fine.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy