0

I have a problem with ubuntu 13.10 terminal (release version, not beta), for example, I created a C program that creates child processes in a mesh, the problem is that when I create a sequence of 3 or more sequency children and run the pstree command to show the tree mesh of processes, is not fit or something, cuts it with a "+" as there are more but do not fit.

3x3 mesh example:

It should show the following (in ubuntu 12.04 shows this):

roberto@rcanovas:-$ pstree -p | grep mash

-gnome-terminal(2085)-+-bash(2116)---mash(2481)-+-mash(2482)---mash(2484)---mash(2487)                                                                                                              |-mash(2483)---mash(2486)---mash(2489)                                                                                                              `-mash(2485)---mash(2488)---mash(2490)

However, it shows the following:

roberto@rcanovas:-$ pstree -p | grep mash

-gnome-terminal(2085)-+-bash(2116)---mash5x5(2481)-+-mash(2482)---mash(2484)-+                                                                                                                      |-mash(2483)---mash(2486)-+                                                                                                                      `-mash(2485)---mash(2487)-+

I tried with konsole and xterm and same result.

Can anyone help? Thank you very much.

0

Try adding the -l or --long option

-l     Display long lines. By default, lines are truncated to the  dis‐
       play  width or 132 if output is sent to a non-tty or if the dis‐
       play width is unknown.

See man pstree

| improve this answer | |
  • Thank you very much. I could swear I looked twice pstree help and had not seen the long parameter... – rcanovas Oct 17 '13 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.