130

I installed Ubuntu today and since the first start up I have a problem with the mouse cursor.

It starts randomly disappearing and flickering a lot.

I have searched for a solution on Google and here but didn't find anything.

  • Welcome! How is your mouse connected (USB maybe)? Try with another mouse device and see what happens. Also you may try plugging into another port – Lucio Oct 17 '13 at 19:04
  • Its happening in 14.04 as well and this trick saved my time. – Nagendhiran Apr 13 '14 at 3:33
  • if you are having flickering in chrome only , try this answer, adding one section to the 20-intel.conf file fixed my issues with flicker in chrome. askubuntu.com/questions/766725/… – Brandon Søren Culley May 18 '18 at 15:19
208

I had the same problem. You can fix it manually. Open System Settings > Displays. In the Displays window, you will see an Unknown monitor. Click it and disable it.

|improve this answer|||||
  • 2
    And to remove that screen you can follow this: askubuntu.com/a/365017/34385 – Jeggy Oct 25 '13 at 8:23
  • 8
    Great! How did you figure out?? – sobi3ch Oct 28 '13 at 11:43
  • 2
    There is no unknown display for me. But I can see 2 built in display in red and green color. I tried disabling one of those alternatively but that also didn't solved my issue. Please help – Vishal Vijay Nov 22 '13 at 5:16
  • 1
    Ho sorry... Disabling the green built in display solved the issue. Thanks – Vishal Vijay Nov 22 '13 at 5:24
  • This didn't work in my case (I had no "Unknown Monitor"). I have posted a question here but given that the OP is a superset of my question I think this answer should provide other possible solutions (or at least avenues to investigate). – quant Nov 23 '14 at 21:09
1

Possible cause 1:

Screen settings: resolution and refresh rate. Can be checked (On KDE) under systemsettings5 then display and monitor

Possible cause 2:

Screen compositor: it could be caused by the sale-method/rendering-backend/tearing-prevention those settings can be changed (On KDE) under systemsettings5, display and monitor then compositor... apply new settings and compare

Possible cause 3:

Display server mis-configuration: you can regenerate the display server config file with X -configure or similar but first make a copy of /etc/X11

Possible cause 4:

System failure, crash, reboot: on system failure especially for systems equipped with SSD you may loose important files; Files under directories like /home/user/, /etc/ or /usr/ can cause serious damages, as these directories contain important settings/packages files for different aspect of the desktop. usually when a file is lost after a crash, the file may be completely deleted or zeroed, you can then search for file with zero size and check out if important file are corrupted with the command find /etc -size 0 -print (this is for /etc) you can also check packages integrity for missing/modified file, on rpm based system it's done with the command rpm -Va you would then reinstall the broken package.

A common situation in this case is loosing the file /etc/X11/xorg.conf or one of the config file under /etc/X11/ responsible for the display server; If recovering the file is not possible the config can be regenerated with X -configure or similar command

Possible cause 5:

Mis-configuration of user files under /home/user... you can verify this by login with an other user... to fix it eventually delete and recreate the user (after backup)

Possible cause 7:

Graphic drivers, you need to check if you are using the proper graphic driver and or try a different version of the used driver, usually this often happen with nvidia graphical cards.

Other...

The listed situations are not the only possibilities of failure.

|improve this answer|||||
0

I ran, from within 16.04, the command:

  sudo apt-get upgrade

and it seems to have appeased the pointer, so far. I had instability, especially over the Chrome browser tabs.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.