20

After upgrading to 13.10 I'm unable to use Dash. Nothing appears when I type something, I don't see any icons or shortcuts.

Resetting unity does not help, the command is unavailable.

What should I do?

  • 1
    how did you reset unity? I believe unity --reset was deprecated. can you try creating a new user and see if that works? – Dan Oct 17 '13 at 18:22
  • Thanks . I have a same problem here . and I got the answer here. Now my Search is working again after running : sudo apt-get install unity-scope-home – user292433 Jun 11 '14 at 1:58
32

It appears that unity-scope-home got uninstalled in the update. So running

sudo apt-get install unity-scope-home 

in a shell should do the trick.

I recommend logging out and in again after installing the package as unity reset seems not to do the trick completely.

| improve this answer | |
9

You can apply the ubuntu-desktop task, it'll install all missing packages (especially unity-scope-* pkgs) :

sudo apt-get install ubuntu-desktop^

it's strange that the upgrade tool doesn't do it

| improve this answer | |
2

The only solution I found was to reinstall Unity lens, as follow:

sudo apt-get install --reinstall unity-lens-* unity-scope-home

Reference: http://adec.altervista.org/blog/ubuntu_13-10_upgrade_issues/

| improve this answer | |
1

OK, first want to thank the guys above for suggestions. None of these worked for me unfortunatelly.

I am using Ubuntu 13.10 and spent lots of time searching for solution online, again, no success.

Then I tried this:

  1. Open System Settings (the gear icon)
  2. Under System, open Software & Updates
  3. Under Software & Updates, select Additional Drivers tab In there I was using open source "X.Org X Server - Noeveau display driver". I looked for one that says "proprietary,tested" and selected that one (in my case, it is "NVIDIA binary Xorg driver, kernel module and VDPAU library from nvidia-319 (proprietary,tested).
  4. Click Apply Changes button and once done, reboot.

After this, for the first time, I am able to click on Unity Dash icon without it freezig my laptop and me having no other choice but to hard reboot it.

Hope this helps to other people, too. Thanks,

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.