30

In 13.04 or below I only needed to access the keyboard layout and then click on the Options button as seen in the image below:

enter image description here

In 13.10 the Options button is missing as seen in the following image:

enter image description here

So what is the new method to access any and all Keyboard Layout Options. In my case I wish to activate 3 of them, from killing X, to some custom keys.

  • This a bug on Ubuntu 13.10 Can't set keyboard layout change to alt+shift, ctrl+shift, etc. – Charin Oct 18 '13 at 10:43
  • 3
    The bug report is about an issue with the key combination to change the keyboard layout (e.g. between English and French) and a fix has already been released in "proposed". The rest of the options can now be changed in gnome-tweak-tool. It doesn't look like the layout options dialog is going to come back, so you can reopen this question. – Joni Oct 24 '13 at 7:12
  • @Joni Thanks for clarifying this. Will wait 24 hours for more information regarding this issue. If I see other issues have been solved I will reopen to see if somebody knows of a change in the behavior. – Luis Alvarado Oct 24 '13 at 14:09
  • @luis-alvardado You can also use dconf-editor for the other settings, which I just put in an answer to Switch caps lock – chaskes Oct 25 '13 at 16:29
  • @chaskes setting switch key using gnome-tweak-tool does not work in Ubuntu 13.10, it is handled by some app (that even steals focus when shortcut is pressed). – kolen Oct 31 '13 at 12:50
13

That's what GNOME developers decided. Instead, you can access equivalent setting menu in gnome-tweak-tool.

Try install gnome-tweak-tool in official repository and go to typing section.

  • Well, I had gnome-tweak-tool already in 13.04 and it was upgraded. HOWEVER when starting it quickly pops up its window and then segfaults. Tried sudo reinstall gnome-tweak-tool which did the reinstall alright, but it still segfaults.... Really a pain I do need to write in German regularly but am using an "En" (US) keyboard all the time for reasonable programming.... Now I'm really severely handicapped with ubuntu 13.10 as opposed to 13.04 and earlier: I definitely want to get "R-Alt" (Alt to the right of space bar) to work as temporary switch to the (Swiss) German kbd layout! – Martin Mächler Feb 19 '14 at 7:19
  • gnome-tweak-tool from the terminal emits the following: WARNING : Shell not installed or running INFO : GSettings missing key org.gnome.nautilus.desktop (key computer-icon-visible) WARNING : Error detecting shell Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/gtweak/tweaks/tweak_shell_extensions.py", line 199, in init raise Exception("Shell not running or DBus service not available") Exception: Shell not running or DBus service not available WARNING: Shell not running None INFO : GSettings missing key org.gnome.mutter (key workspaces-only-on-primary) – Martin Mächler Feb 19 '14 at 8:16
11

It seems that this is by design; there has been a reorganization of the keyboard/input methods. Now the keyboard configuration is accessed by system settings -> keyboard, tab shortcut, Typing entries:

keyboard typing shortcuts

But quite a lot of options is just not here anymore, like the settings for ctrl-alt-backspace.

There is now a specific issue opened in Launchpad to ask that back: https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1245064

By the way, on Nov. 2, 2013, there are still quite a handful of bugs with the change, which you can explore with the quite long and detailed list of related bug linked in the description of the issue aforementioned.

  • That's the window I get, but the entry with Compose Key says "disabled" and I can't find a way to enable it. – Christine Apr 22 '14 at 16:01
  • @Christine I have just Xubuntu available now, but you should be able to select the whole line with Compose and then clicking on "Disabled" you should have a menu with the possible Compose Key(s). – Rmano Apr 22 '14 at 16:25
  • @Rmano On Ubuntu I do not have the entries "Switch to next/previous input source"!? – JJD Jun 16 '14 at 14:55
11

It's still possible to make the change from the command line using dpkg. Credit goes to this site: http://www.humans-enabled.com/2013/10/ubuntu-1310-enable-controlaltbackspace.html. To sum up what's written there, you can open a terminal and enter

sudo dpkg-reconfigure keyboard-configuration

This will take you through a series of options for the keyboard; for the first 4 or 5 just hit enter to keep things as is, and you'll end up with the option to enable Ctrl-Alt-Backspace.

  • This was helpful - I used it to remove the ctrl / caps lock swapping that I'd set up but couldn't access any longer. Even though it didn't ask me about that particular config, it did appear to clean it out. – jamesc Mar 29 '14 at 10:41
0

Look into the "Keyboard" and delete all languages except the language you want. Save the changes. Th eproblem should be fixed

0

Use the shortcut key to switch back to the US keyboard source. In System Settings > Keyboard, select the Shortcuts tab, then select Typing. Try pressing the key combination shown as Switch to previous source or Switch to next source.

I bet that Tor M's solution would have the same effect.

I discovered this because I installed Japanese language and intentionally switched to Japanese. Then I recognized that the punctuation symbols moved to their locations on a Japanese keyboard. So I just used the keyboard shortcut again to switch back to the US English keyboard.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.