2

With 13.04 and earlier X2go started up Lubuntu with the command startlubuntu. This is gone from 13.10 and I tracked down that it was replaced by lxsession. However, if I try to start up my desktop with lxsession I just get a blank desktop.

What is the proper command line replacement for startlubuntu?

Update: Xrdp has the same problem. I can tell lxde is running because the Guake message shows up but there's no desktop or anything else.

1

I had the same problem, I've submitted a bug and I'd appreciate you click the 'this bug affects' me button:

https://bugs.launchpad.net/ubuntu/+source/lubuntu-default-settings/+bug/1241958

So here's a workaround:

First if you cant get /usr/bin/lxsession or /usr/bin/lxsession to work through the LATEST x2go client try this:

1) uninstall the latest x2go client and reinstall (I'm using the latest preview version) 2) purge your x2go install: 'apt-get remove purge x2go*' (check what x2go packages are installed with 'dpkg -l | grep x2go' and remove them such as libx2go*) 3) Follow the instructions here to get the latest server:

http://wiki.x2go.org/doku.php/doc:installation:x2goserver

I installed python-software-properties, x2goserver, x2goserver-xsession and x2golxdebindings

make sure you are using that ppa repository so you get the latest versions

4) kill all running x2go server sessions on the server and restart 5) reconnect with x2go client and use 'custom' session type with /usr/bin/startlxde (or try /usr/bin/lxsession). If this doesn't work, then something is still wrong with your setup 6) If you want to use startlubuntu you can still download the deb from here:

http://packages.ubuntu.com/raring/all/lubuntu-default-settings/download

and extract it with

sudo depkg-deb -x lubuntu-default-settings_0.31_all.deb ./temp

go into temp/usr/bin/ and copy 'startlubuntu' to /usr/bin/ on your server. This script should still work with 13.10 until we can find out the proper way to make this work with lxsession (you should subscribe to that bug so you can be part of the discussion to find out the right way to do this).

0

I had a similar problem with Lubuntu 14.04 as the x2go server : I could not connect. Following this thread , I ran the following command on the server :

sudo apt-get install --no-install-recommends lxde

And it works now (although the desktop is the not the same as through a regular VM access).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.